summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-12-18 06:10:11 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-19 18:56:34 +0000
commitb654a85c76470c0e7d77d2f4c830a45b820501f0 (patch)
tree15ea11489c98dcd6c3b988897eb7240c7701ef68
parente4c55862f7676997c630ef15ba4840a83dfbbf82 (diff)
Add libnfc recipes.
libnfc is mandatory for agl service nfc. Change-Id: Ie542178c71a1b34b6925b3c2322a1386b7866fa1 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--recipes-connectivity/libnfc/libnfc_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-connectivity/libnfc/libnfc_git.bb b/recipes-connectivity/libnfc/libnfc_git.bb
new file mode 100644
index 00000000..bd216f81
--- /dev/null
+++ b/recipes-connectivity/libnfc/libnfc_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "libnfc"
+DESCRIPTION = "Platform independent Near Field Communication (NFC) library"
+HOMEPAGE = "https://github.com/nfc-tools/libnfc"
+SECTION = "apps"
+
+DEPENDS = "libusb"
+
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
+
+inherit cmake pkgconfig
+
+SRC_URI = "git://github.com/nfc-tools/libnfc;protocol=https;branch=master"
+SRCREV = "2d4543673e9b76c02679ca8b89259659f1afd932"
+
+PV = "1.7.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+