summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>2017-12-14 19:00:43 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-12-18 19:52:11 +0000
commit034113162aadc8490c376feb060053a8a4099520 (patch)
tree328abafd8abb9d8ad87696eda2cdf6ee347ee762
parent2e7d61c3405f6407ac1c4bde6ff1ebd972974749 (diff)
Enable the AGL Navigation API library for C++
Add AGL Navigation API library to rootfs and SDK. This change is necessary change for CES 2018 version POI App to commit in the future. Change-Id: I08996778dd858ee2d3c91e47defa1d6846c28bf9 Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
-rwxr-xr-x[-rw-r--r--]recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb2
-rwxr-xr-xrecipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb16
-rwxr-xr-xrecipes-platform/packagegroups/packagegroup-agl-demo-platform.bb6
3 files changed, 23 insertions, 1 deletions
diff --git a/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb b/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb
index 933d47d4..0c245b3e 100644..100755
--- a/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb
+++ b/recipes-demo-hmi/agl-service-navigation/agl-service-navigation_git.bb
@@ -7,7 +7,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
-SRCREV = "b75e80244471e3486176e5ba476989410ecf5bda"
+SRCREV = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
diff --git a/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb b/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
new file mode 100755
index 00000000..af528ff6
--- /dev/null
+++ b/recipes-demo-hmi/libnaviapi-agl/libnaviapi-agl_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "AGL Navigation API Library"
+DESCRIPTION = "AGL Navigation API ver 0.1.0 library for C++"
+HOMEPAGE = "https://github.com/AGLExport/agl-service-navigation"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c libdbus-c++ af-main-native"
+
+inherit cmake
+
+SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
+SRCREV = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
+S = "${WORKDIR}/git"
+
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 68270ff2..6d0157ff 100755
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -57,6 +57,11 @@ AGL_APPS = " \
low-can-demo \
"
+AGL_APIS = " \
+ libnaviapi-agl \
+ "
+
+
RDEPENDS_${PN}_append = " \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
@@ -64,6 +69,7 @@ RDEPENDS_${PN}_append = " \
${MAPVIEWER} \
${MOST_HVAC} \
${AGL_APPS} \
+ ${AGL_APIS} \
"