summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-10-14 02:08:32 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-10-14 03:44:29 +0200
commitec26de7ad1430322731f1424e72c4a2f7584cbd3 (patch)
tree802489256d09db4f8f5caf3d2e1cda481a3b1b5f
parentbaecf0edf5f3e3e5a097102b727caa608620075f (diff)
Adapt packages of agl-image-ivi-crosssdk
The agl-image-ivi-crosssdk image was missing multiple services required for CI use. Bug-AGL: SPEC-3598 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: Ide6a367955b9a019863d7b29e04157c94dd33f60
-rw-r--r--recipes-platform/images/agl-image-ivi-crosssdk.bb11
-rw-r--r--recipes-platform/images/agl-image-ivi.bb5
-rw-r--r--recipes-platform/images/agl-image-ivi.inc13
3 files changed, 22 insertions, 7 deletions
diff --git a/recipes-platform/images/agl-image-ivi-crosssdk.bb b/recipes-platform/images/agl-image-ivi-crosssdk.bb
index 93537feb4..72bf8f7b0 100644
--- a/recipes-platform/images/agl-image-ivi-crosssdk.bb
+++ b/recipes-platform/images/agl-image-ivi-crosssdk.bb
@@ -1,2 +1,9 @@
-# just for backward compatibility
-require recipes-platform/images/agl-image-minimal-crosssdk.bb
+require recipes-platform/images/agl-image-minimal-crosssdk.inc
+require agl-image-ivi.inc
+
+inherit populate_sdk
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
diff --git a/recipes-platform/images/agl-image-ivi.bb b/recipes-platform/images/agl-image-ivi.bb
index 1e5870062..b3c72de0c 100644
--- a/recipes-platform/images/agl-image-ivi.bb
+++ b/recipes-platform/images/agl-image-ivi.bb
@@ -6,8 +6,3 @@ require agl-image-ivi.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
- packagegroup-agl-image-ivi \
- "
-
-DISTRO_FEATURES_append = " agl-core-image-profile"
diff --git a/recipes-platform/images/agl-image-ivi.inc b/recipes-platform/images/agl-image-ivi.inc
index 610d4e464..95b6ca688 100644
--- a/recipes-platform/images/agl-image-ivi.inc
+++ b/recipes-platform/images/agl-image-ivi.inc
@@ -1,3 +1,16 @@
require recipes-platform/images/agl-image-minimal.inc
+IMAGE_INSTALL_append = "\
+ packagegroup-agl-image-ivi \
+ packagegroup-agl-ivi-services \
+ agl-service-homescreen \
+ agl-service-weather \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'pipewire', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-mediaplayer', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-radio', '', d)} \
+ can-utils \
+ iproute2 \
+ "
+
IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+DISTRO_FEATURES_append = " agl-core-image-profile"
} /* Name.Class */ .highlight .no { color: #66d9ef } /* Name.Constant */ .highlight .nd { color: #a6e22e } /* Name.Decorator */ .highlight .ni { color: #f8f8f2 } /* Name.Entity */ .highlight .ne { color: #a6e22e } /* Name.Exception */ .highlight .nf { color: #a6e22e } /* Name.Function */ .highlight .nl { color: #f8f8f2 } /* Name.Label */ .highlight .nn { color: #f8f8f2 } /* Name.Namespace */ .highlight .nx { color: #a6e22e } /* Name.Other */ .highlight .py { color: #f8f8f2 } /* Name.Property */ .highlight .nt { color: #f92672 } /* Name.Tag */ .highlight .nv { color: #f8f8f2 } /* Name.Variable */ .highlight .ow { color: #f92672 } /* Operator.Word */ .highlight .w { color: #f8f8f2 } /* Text.Whitespace */ .highlight .mb { color: #ae81ff } /* Literal.Number.Bin */ .highlight .mf { color: #ae81ff } /* Literal.Number.Float */ .highlight .mh { color: #ae81ff } /* Literal.Number.Hex */ .highlight .mi { color: #ae81ff } /* Literal.Number.Integer */ .highlight .mo { color: #ae81ff } /* Literal.Number.Oct */ .highlight .sa { color: #e6db74 } /* Literal.String.Affix */ .highlight .sb { color: #e6db74 } /* Literal.String.Backtick */ .highlight .sc { color: #e6db74 } /* Literal.String.Char */ .highlight .dl { color: #e6db74 } /* Literal.String.Delimiter */ .highlight .sd { color: #e6db74 } /* Literal.String.Doc */ .highlight .s2 { color: #e6db74 } /* Literal.String.Double */ .highlight .se { color: #ae81ff } /* Literal.String.Escape */ .highlight .sh { color: #e6db74 } /* Literal.String.Heredoc */ .highlight .si { color: #e6db74 } /* Literal.String.Interpol */ .highlight .sx { color: #e6db74 } /* Literal.String.Other */ .highlight .sr { color: #e6db74 } /* Literal.String.Regex */ .highlight .s1 { color: #e6db74 } /* Literal.String.Single */ .highlight .ss { color: #e6db74 } /* Literal.String.Symbol */ .highlight .bp { color: #f8f8f2 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #a6e22e } /* Name.Function.Magic */ .highlight .vc { color: #f8f8f2 } /* Name.Variable.Class */ .highlight .vg { color: #f8f8f2 } /* Name.Variable.Global */ .highlight .vi { color: #f8f8f2 } /* Name.Variable.Instance */ .highlight .vm { color: #f8f8f2 } /* Name.Variable.Magic */ .highlight .il { color: #ae81ff } /* Literal.Number.Integer.Long */ } @media (prefers-color-scheme: light) { .highlight .hll { background-color: #ffffcc } .highlight .c { color: #888888 } /* Comment */ .highlight .err { color: #a61717; background-color: #e3d2d2 } /* Error */ .highlight .k { color: #008800; font-weight: bold } /* Keyword */ .highlight .ch { color: #888888 } /* Comment.Hashbang */ .highlight .cm { color: #888888 } /* Comment.Multiline */ .highlight .cp { color: #cc0000; font-weight: bold } /* Comment.Preproc */ .highlight .cpf { color: #888888 } /* Comment.PreprocFile */ .highlight .c1 { color: #888888 } /* Comment.Single */ .highlight .cs { color: #cc0000; font-weight: bold; background-color: #fff0f0 } /* Comment.Special */ .highlight .gd { color: #000000; background-color: #ffdddd } /* Generic.Deleted */ .highlight .ge { font-style: italic } /* Generic.Emph */ .highlight .gr { color: #aa0000 } /* Generic.Error */ .highlight .gh { color: #333333 } /* Generic.Heading */ .highlight .gi { color: #000000; background-color: #ddffdd } /* Generic.Inserted */ .highlight .go { color: #888888 } /* Generic.Output */ .highlight .gp { color: #555555 } /* Generic.Prompt */ .highlight .gs { font-weight: bold } /* Generic.Strong */ .highlight .gu { color: #666666 } /* Generic.Subheading */ .highlight .gt { color: #aa0000 } /* Generic.Traceback */ .highlight .kc { color: #008800; font-weight: bold } /* Keyword.Constant */ .highlight .kd { color: #008800; font-weight: bold } /* Keyword.Declaration */ .highlight .kn { color: #008800; font-weight: bold } /* Keyword.Namespace */ .highlight .kp { color: #008800 } /* Keyword.Pseudo */ .highlight .kr { color: #008800; font-weight: bold } /* Keyword.Reserved */ .highlight .kt { color: #888888; font-weight: bold } /* Keyword.Type */ .highlight .m { color: #0000DD; font-weight: bold } /* Literal.Number */ .highlight .s { color: #dd2200; background-color: #fff0f0 } /* Literal.String */ .highlight .na { color: #336699 } /* Name.Attribute */ .highlight .nb { color: #003388 } /* Name.Builtin */ .highlight .nc { color: #bb0066; font-weight: bold } /* Name.Class */ .highlight .no { color: #003366; font-weight: bold } /* Name.Constant */ .highlight .nd { color: #555555 } /* Name.Decorator */ .highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
<html>
<head>
<!--
 * Copyright (C) 2017 "IoT.bzh"
 * Author: José Bollo <jose.bollo@iot.bzh>
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *   http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
-->
    <title>Monitoring</title>
    <link href="monitor-base.css" rel="stylesheet">
    <link href="monitor-demo.css" rel="stylesheet" title="demo">
    <link href="monitor-pastel.css" rel="alternate stylesheet" title="pastel">
    <script type="text/javascript" src="underscore-min.js"></script>
    <script type="text/javascript" src="AFB.js"></script>
    <script type="text/javascript" src="monitor.js"></script>

<body id="root" class="-flex-v on" onload="init();">
  <div id="head" class="clearfix">
    <div id="logo"></div>
    <div id="connected">Not Connected</div>
    <div id="title">Monitoring</div>
  </div>
  <div id="work" class="-flex-fill -flex-h">
    <div id="controls" class="-box-out">
      <div class="-box-in">
        <div id="all" class="api opened" data-api="*">
          <div class="opclo"></div>
          <div class="name">{ALL}</div>
          <div class="desc">Settings for all</div>
          <hr>
          <div class="verbosity">placeholder</div>
          <hr class="closedoff">
          <div class="closedon">traces...</div>
          <div class="trace closedoff"></div>
        </div>
        <div id="common" class="api" data-api="">
          <div class="name">{COMMON}</div>
          <div class="desc">Settings without apis</div>
          <hr>
          <div class="verbosity">placeholder</div>
        </div>
        <div id="apis">
        </div>
      </div>
    </div>
    <div id="middle" class="-flex-v">
      <div id="params" class="clearfix">
        <div>host: <input type="text" id="param-host" size="50" value="localhost"></input></div>
        <div>port: <input type="text" id="param-port" size="10" value="1234"></input></div>
        <div>token: <input type="text" id="param-token" size="33" value="hello"></input></div>
      </div>
      <div class="-flex-fill -box-out">
        <div id="trace-events" class="-box-in">
        </div>
      </div>
    </div>

      <div id="menu" class="-flex-v">
        <div id="connect" class="x-button">Connect</div>
        <div id="disconnect" class="x-button">Disconnect</div>
        <div id="style" class="x-button">style</div>
        <div id="autoscroll" class="x-button">Stop scroll</div>
        <div id="addsep" class="x-button">Add separator</div>
        <div id="droptracevts" class="x-button">Clear traces</div>
        <div id="experts" class="x-button closed">
          <div class="opclo"></div>
          {EXPERTS}
        </div>
        <div id="expert-pane" class="-flex-fill -flex-v">
          <div id="stopmsgs" class="x-button">Stop logs</div>
          <div id="dropmsgs" class="x-button">Clear logs</div>
          <div class="-flex-fill -box-out">
              <div id="logmsgs" class="-box-in"></div>
          </div>
        </div>
      </div>
  </div>

<!-- template for APIS -->
  <template id="t-api">
    <div class="api closed" data-api="">
      <div class="opclo"></div>
      <div class="name"></div>
      <div class="desc"></div>
      <div class="closedoff">
        <hr>
        <div class="verbosity">placeholder</div>
        <hr>
        <div class="closed">
          <div class="opclo"></div>
          <div class="closedon">verbs...</div>
          <div class="verbs closedoff"></div>
        </div>
        <div class="closed">
          <div class="opclo"></div>
          <div class="closedon">traces...</div>
          <div class="trace closedoff"></div>
        </div>
      </div>
    </div>
  </template>

<!-- template for VERBS of APIS -->
  <template id="t-verb">
    <div class="verb" data-verb="">
      <div class="vdsc">
        <span class="name"></span>
        <span class="colon">:</span>
        <span class="desc"></span>
      </div>
      <div class="perm"></div>
    </div>
  </template>

<!-- template for ERRORS -->
  <template id="t-logmsg">
    <div class="logmsg">
      <div class="close"></div>
      <div class="tag"></div>
      <div class="content"></div>
    </div>
  </template>

<!-- template for VERBOSITY -->
  <template id="t-verbosity">
    <div class="verbosity">
      <span>Verbosity:</span>
      <select class="select">
        <option value="error">error</option>
        <option value="warning">warning</option>
        <option value="notice">notice</option>
        <option value="info">info</option>
        <option value="debug">debug</option>
      </select>
    </div>
  </template>

<!-- template for TRACE -->
  <template id="t-trace">
    <div class="trace closedoff">
      <div class="trace-box request" data-trace="request">
        <div class="trace-title">trace requests: <a target="_blank" href="http://docs.automotivelinux.org/docs/apis_services/en/dev/reference/af-binder/afb-binding-references.html#functions-of-class-afbreq">(doc)</a></div>
        <div class="trace-item"><input type="radio" value="no" checked>no</input></div>
        <div class="trace-item"><input type="radio" value="common">common</input></div>
        <div class="trace-item"><input type="radio" value="extra">extra</input></div>
        <div class="trace-item"><input type="radio" value="all">all</input></div>
      </div>
      <div class="trace-box service" data-trace="service">
        <div class="trace-title">trace service call: <a target="_blank" href="http://docs.automotivelinux.org/docs/apis_services/en/dev/reference/af-binder/afb-binding-references.html#functions-of-class-afbservice">(doc)</a></div>
        <div class="trace-item"><input type="radio" value="no" checked>no</input></div>
        <div class="trace-item"><input type="radio" value="all">all</input></div>
      </div>
      <div class="trace-box daemon" data-trace="daemon">
        <div class="trace-title">trace daemon: <a target="_blank" href="http://docs.automotivelinux.org/docs/apis_services/en/dev/reference/af-binder/afb-binding-references.html#functions-of-class-afbdaemon">(doc)</a></div>
        <div class="trace-item"><input type="radio" value="no" checked>no</input></div>
        <div class="trace-item"><input type="radio" value="common">common</input></div>
        <div class="trace-item"><input type="radio" value="extra">extra</input></div>
        <div class="trace-item"><input type="radio" value="all">all</input></div>
      </div>
      <div class="trace-box event" data-trace="event">
        <div class="trace-title">trace events: <a target="_blank" href="http://docs.automotivelinux.org/docs/apis_services/en/dev/reference/af-binder/afb-binding-references.html#functions-of-class-afbevent">(doc)</a></div>
        <div class="trace-item"><input type="radio" value="no" checked>no</input></div>
        <div class="trace-item"><input type="radio" value="common">common</input></div>
        <div class="trace-item"><input type="radio" value="extra">extra</input></div>
        <div class="trace-item"><input type="radio" value="all">all</input></div>
      </div>
      <div class="trace-box global" data-trace="global">
        <div class="trace-title">trace globals:</div>
        <div class="trace-item"><input type="radio" value="no" checked>no</input></div>
        <div class="trace-item"><input type="radio" value="all">all</input></div>
      </div>
    </div>
  </template>

<!-- template for EVENTS -->
  <template id="t-traceevent">
    <div class="traceevent closed">
      <div class="close"></div>
      <div class="time"></div>
      <div class="tag"></div>
      <div class="content"></div>
    </div>
  </template>

<!-- template for SEPARATOR -->
  <template id="t-separator">
    <div class="separator"></div>
  </template>