summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2016-12-27 12:43:32 +0100
committerRomain Forlot <romain.forlot@iot.bzh>2016-12-27 12:47:13 +0100
commitdd70c8c5298a1fea8b2ff2be50536af777b9dfaa (patch)
tree86b7d61d8f954106fd36b6dcbad5ddd6e7cb460f
parent2fceebaccdbd1210f095f139c8358aa8ff635e65 (diff)
Fix: SPEC-377, miss dbus conf file to make status icon working
Change-Id: I8b64adf1c73244447f348ae140a4bd63d3796357 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
-rw-r--r--recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in6
-rw-r--r--recipes-demo-hmi/homescreen/homescreen_git.bb8
2 files changed, 13 insertions, 1 deletions
diff --git a/recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in b/recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in
new file mode 100644
index 000000000..a79d70f72
--- /dev/null
+++ b/recipes-demo-hmi/homescreen/homescreen/dbus-homescreen.conf.in
@@ -0,0 +1,6 @@
+<?xml version="1.0"?> <!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+ <policy context="default">
+ <allow send_destination="org.agl.homescreen"/>
+ </policy>
+</busconfig>
diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
index e03b14d3a..2115804b1 100644
--- a/recipes-demo-hmi/homescreen/homescreen_git.bb
+++ b/recipes-demo-hmi/homescreen/homescreen_git.bb
@@ -25,7 +25,8 @@ SRCREV = "${AUTOREV}"
PV = "0.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
- file://homescreen.pc.in "
+ file://homescreen.pc.in \
+ file://dbus-homescreen.conf.in"
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
@@ -44,6 +45,11 @@ do_install() {
ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1
ln -sf libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
+# claneys: add dbus policy to make wifi/bluetooth status icon working as quick
+# workaround. (jira.automotivelinux.org : SPEC-377)
+ install -d ${D}/etc/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/dbus-homescreen.conf.in ${D}/etc/dbus-1/session.d/homescreen.conf
+
# kooltux: still some problem with paths inside .pc file
# error at build time:
# ERROR: homescreen-git-r0 do_populate_sysroot: QA Issue: homescreen.pc failed sanity test (tmpdir) in path /xdt/build/tmp/work/cortexa15hf-neon-agl-linux-gnueabi/homescreen/git-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig]
ht .nb { color: #003388 } /* Name.Builtin */ .highlight .nc { color: #bb0066; font-weight: bold } /* Name.Class */ .highlight .no { color: #003366; font-weight: bold } /* Name.Constant */ .highlight .nd { color: #555555 } /* Name.Decorator */ .highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
[Unit]
Description=Image mount for drl-lease-test-cluster

[Mount]
What=/var/lib/machines/guest-image-drm-lease-test-cluster.ext4
Where=/var/lib/machines/guest1
Type=ext4
Options=rw

[Install]
WantedBy=local-fs.target