aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-16 20:51:25 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-16 21:08:44 -0500
commit16cac4f041601038a32ae39d94e8bd835f2fff7e (patch)
tree8a89c6d344825b30d8e8a1e27e0eeae09f460e9c
parentf63de93fda2dfbf8f1f1dd807a6a8c83aca39369 (diff)
poiapp-api-key: Add client ID
Somehow in my original testing the POI app was working even though the client ID was not being added to /etc/poikey as the first line. Add a POIAPP_CLIENT_ID variable to go with POIAPP_API_KEY, and write them both to the file. As well, mark the package as platform independent, as it contains just a text configuration file. Change-Id: Iab5d6aa44007c61457697882d9a2ece12f984acf Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rwxr-xr-xrecipes-demo-hmi/navigation/poiapp-api-key_1.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
index ad6546fe..4d53fdbf 100755
--- a/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
+++ b/recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb
@@ -9,9 +9,13 @@ do_fetch[noexec] = "1"
do_unpack[noexec] = "1"
do_compile[noexec] = "1"
+POIAPP_CLIENT_ID ?= ""
POIAPP_API_KEY ?= ""
do_install () {
install -d ${D}${sysconfdir}
- echo "${POIAPP_API_KEY}" > ${D}${sysconfdir}/poikey
+ echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
+ echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
}
+
+PACKAGE_ARCH = "all"