aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-12-03 14:29:19 -0500
committerScott Murray <scott.murray@konsulko.com>2018-12-03 14:31:34 -0500
commitaf3ecc175fdb3cfbb7501ec5f1aad7718c08472a (patch)
tree6495dc2a1ec78a4d427c697d75b3642db8dd7e11
parent036967635cb603be7e7186dc7f5c51d348ccd0bd (diff)
Add agl-cluster-demo-support feature
Add new feature to enable support for the cluster demo. At the moment, it pulls in the agl-gstrecorder feature and enables building the required mapviewer application. Bug-AGL: SPEC-1730 Change-Id: I18c0312eefca9bb8c591e8b8a2b8113b4e94c7fc Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rwxr-xr-xrecipes-platform/packagegroups/packagegroup-agl-demo-platform.bb10
-rw-r--r--templates/feature/agl-cluster-demo-support/50_local.conf.inc1
-rw-r--r--templates/feature/agl-cluster-demo-support/included.dep1
3 files changed, 7 insertions, 5 deletions
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index f3191ca1..9deaea2a 100755
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -37,9 +37,6 @@ MOST_HVAC_append = " \
MOST_HVAC_dra7xx-evm = ""
MOST_HVAC_dragonboard-410c = ""
-# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"
-
AGL_APPS = " \
dashboard \
hvac \
@@ -61,15 +58,18 @@ AGL_APIS = " \
QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
+# mapviewer and mapviewer-demo are required for AGL cluster demo
+MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
+
RDEPENDS_${PN}_append = " \
qtquickcontrols2-agl \
qtquickcontrols2-agl-style \
linux-firmware-ralink \
- ${QTAGLEXTRAS} \
- ${MAPVIEWER} \
${MOST_HVAC} \
${AGL_APPS} \
${AGL_APIS} \
+ ${QTAGLEXTRAS} \
+ ${MAPVIEWER} \
"
diff --git a/templates/feature/agl-cluster-demo-support/50_local.conf.inc b/templates/feature/agl-cluster-demo-support/50_local.conf.inc
new file mode 100644
index 00000000..f4724b58
--- /dev/null
+++ b/templates/feature/agl-cluster-demo-support/50_local.conf.inc
@@ -0,0 +1 @@
+DISTRO_FEATURES_append = " agl-cluster-demo-support"
diff --git a/templates/feature/agl-cluster-demo-support/included.dep b/templates/feature/agl-cluster-demo-support/included.dep
new file mode 100644
index 00000000..17ef3ba9
--- /dev/null
+++ b/templates/feature/agl-cluster-demo-support/included.dep
@@ -0,0 +1 @@
+agl-gstrecorder