summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2018-07-24 12:45:15 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-01 10:34:17 +0000
commitb6141a90bcf736fee859efcbae9693b895094394 (patch)
tree6bcc30cd1c0f3230691630586d317f2cba6f6dea
parente5fbebaa4fce6fb0877354fb0ac2f6d6576e6adf (diff)
Remove porter board config
* porter board is not supported any more in AGL Change-Id: Ifad3f089707d772f41d0ac6916348474a284b5b9 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--recipes-demo-hmi/can-lin/can-lin_0.2.bb39
-rw-r--r--recipes-demo-hmi/can-lin/files/hvac-demo.service12
-rw-r--r--recipes-graphics/web-runtime/web-runtime_0.1.bb14
-rwxr-xr-xrecipes-platform/packagegroups/packagegroup-agl-demo-platform.bb2
-rw-r--r--recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb3
5 files changed, 3 insertions, 67 deletions
diff --git a/recipes-demo-hmi/can-lin/can-lin_0.2.bb b/recipes-demo-hmi/can-lin/can-lin_0.2.bb
deleted file mode 100644
index 918b8686..00000000
--- a/recipes-demo-hmi/can-lin/can-lin_0.2.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-DESCRIPTION = "CAN-LIN Application"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https;branch=${AGL_BRANCH}"
-SRC_URI += "file://hvac-demo.service"
-
-S = "${WORKDIR}/git"
-SRCREV = "fd2101e277cb80eef4c6381924cfdc1d50087d12"
-
-# These binaries are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"
-
-do_install() {
- install -m 0755 -d ${D}${bindir}
- install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
- # Hack for vod service for RSE with most/hvac demo hardware
-
- # vod-client is provided as binary stored and delivered in staging/most-can-demo-bin.
- install -m 0755 -d ${D}/usr/AGL/most
- install -m 0755 ${S}/vod-client ${D}/usr/AGL/most
-
- # Install HVAC DEMO hardware startup systemd service (user)
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -m 644 -p -D ${WORKDIR}/hvac-demo.service ${D}${systemd_user_unitdir}/hvac-demo.service
- fi
-
- # Execute install manually for root user on behalf of systemctl script
- # because it doesn't support user mode of systemd.
- install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
- ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service
-}
-
-FILES_${PN} += " \
- ${bindir}/OptoLyzerMoccaApp \
- /usr/AGL/most/vod-client \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/hvac-demo.service', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
- "
diff --git a/recipes-demo-hmi/can-lin/files/hvac-demo.service b/recipes-demo-hmi/can-lin/files/hvac-demo.service
deleted file mode 100644
index 7173f9bf..00000000
--- a/recipes-demo-hmi/can-lin/files/hvac-demo.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description = HVAC DEMO hardware startup
-After=WindowManager.service
-
-[Service]
-Type=simple
-ExecStartPre=-/sbin/ip link add dev vcan0 type vcan
-ExecStartPre=-/sbin/ifconfig vcan0 up
-ExecStart=/usr/bin/openvt -e /usr/bin/OptoLyzerMoccaApp
-
-[Install]
-WantedBy=default.target
diff --git a/recipes-graphics/web-runtime/web-runtime_0.1.bb b/recipes-graphics/web-runtime/web-runtime_0.1.bb
index 75077b69..bdfcbecb 100644
--- a/recipes-graphics/web-runtime/web-runtime_0.1.bb
+++ b/recipes-graphics/web-runtime/web-runtime_0.1.bb
@@ -7,9 +7,9 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
SRC_URI = "\
- file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
- file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
- file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
+ file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
+ file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
+ file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
"
RDEPENDS_${PN} = "\
@@ -32,11 +32,3 @@ do_install() {
install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
}
-
-do_install_append_rcar-gen2() {
- # workaround for porter board: force the use of libEGL provided by mesa at runtime
- # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
- sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
-}
-
-
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index d45d7bac..f5c9f0d4 100755
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -23,8 +23,6 @@ RDEPENDS_${PN} += "\
MOST_DRIVERS = " \
most \
"
-# Don't add MOST support when building for Porter
-MOST_DRIVERS_remove_porter = "most"
# HVAC dependencies depend on drivers above
MOST_HVAC = " "
diff --git a/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
index 7d135356..108e9b7d 100644
--- a/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
+++ b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
@@ -12,6 +12,3 @@ ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
sdl-core \
"
-
-# Porter does not have the required gstreamer version
-RDEPENDS_${PN}_porter := ""