summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-03-24 14:48:14 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-03-24 20:53:06 +0000
commitb66ecfce64806986d49a012caea396d4cc657fd0 (patch)
tree700d82d9b9228b7790ec6696891b0295cc96600d
parentdedd3167b030a5ae9f281ac83a287bd8a463c649 (diff)
html5-hvac_git: Remove autobuild script builds
Bug-AGL: SPEC-4309 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Idef28f993af074f7e43b6475b4b53576572f7d9e (cherry picked from commit bbdac38957c239b73bcbf409be2efceef3e5d6f5)
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 85fed294..16bf739c 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"
do_compile() {
- bldcmd=${S}/autobuild/agl/autobuild
cd ${S}
- $bldcmd build
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -35,4 +36,4 @@ do_install() {
FILES_${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
-" \ No newline at end of file
+"