aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-12-11 19:43:17 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-12 16:58:57 +0000
commitc9276183ce123bd11d0b36ec60fc93386da9ccb8 (patch)
tree94a43f1d669d153941c528792c7534bdb7aefc71
parentbd98391667189c7cc989e90161910bb766c4ca37 (diff)
dashboard: update dependencies
Add libqtappfw to DEPENDS for dashboard app for signal composer event support, and to RDEPENDS as well as new runtime dependency agl-service-signal-composer. Bug-AGL: SPEC-3042 Change-Id: I955f821798d85fbb0f9265ee55b81ff0bd7db620 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo-hmi/dashboard/dashboard_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-demo-hmi/dashboard/dashboard_git.bb b/recipes-demo-hmi/dashboard/dashboard_git.bb
index 7ccbdeae..822207b1 100644
--- a/recipes-demo-hmi/dashboard/dashboard_git.bb
+++ b/recipes-demo-hmi/dashboard/dashboard_git.bb
@@ -13,6 +13,11 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS += "qtquickcontrols2 qttools-native qtaglextras"
+DEPENDS += "qtquickcontrols2 qttools-native qtaglextras libqtappfw"
inherit qmake5 aglwgt
+
+RDEPENDS_${PN} += " \
+ libqtappfw \
+ agl-service-signal-composer \
+"