aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-12-11 07:50:19 +0200
committerMatt Ranostay <matt.ranostay@konsulko.com>2019-12-11 19:43:45 +0200
commitd1c0f32a43fbe5e1bdbab2a8ebdfd7631dec179e (patch)
tree7ef08a633caf04f261290360b762ff837585494d
parentb18b813c543556544e54c41c541fd121fb002378 (diff)
agl-demo-platform-crosssdk: add gcc-sanitizer to TOOLCHAIN_TARGET_TASK
Add gcc-sanitizers package to TOOLCHAIN_TARGET_TASK which allows linking of libasan for detecting use-after-free and other memory corruption issue in built applications/libraries. Bug-AGL: SPEC-3040 Change-Id: Idad618e2bd0e9fa98baa9a3befc694c5bddeb711 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rwxr-xr-xrecipes-platform/images/agl-demo-platform-crosssdk.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index dcd8848f..a814b694 100755
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -74,3 +74,8 @@ TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"
# other users of the C++17 filesystem standard library feature.
# Can be removed upon upgrade to gcc 9.x, as it will no longer be necessary.
TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
+
+# Add gcc-sanitizers to support building applications using the SDK with
+# AddressSanitizer support to detect use-after-frees along with other
+# memory issue.
+TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"