summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Tilve <ltilve@igalia.com>2020-02-06 19:00:44 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-11 21:51:02 +0000
commit5e693e414d090c2a03dad9d98d25916aa7513b87 (patch)
tree8fc5bdfa5d09e2bb976f601387dfbcb45e675568
parentfecd22cab132fd110ac2e9af6893eb4bc39c0be5 (diff)
html5-mixer: create recipe and add to html5 demo
Bug-AGL: SPEC-2824 Change-Id: Icc15a48d2a78dfdd57bf60f050ec0b66c714aefa Signed-off-by: Lorenzo Tilve <ltilve@igalia.com> (cherry picked from commit 383abf8322acf90fbb56551eb8eefaef1854d8d4)
-rw-r--r--recipes-demo-hmi/html5-mixer/html5-mixer_git.bb25
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
new file mode 100644
index 00000000..babef57c
--- /dev/null
+++ b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL HTML5 Mixer Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mixer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+ cd ${B}
+ npm install
+}
+
+do_aglwgt_package() {
+ cd ${B}
+ npm run build
+}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index cddab0ba..3a12c562 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -21,6 +21,7 @@ AGL_APPS = " \
html5-launcher \
html5-hvac \
html5-settings \
+ html5-mixer \
"
RDEPENDS_${PN}_append = " \