summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Shamanin <andrei.shamanin@orioninc.com>2020-07-07 14:31:49 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-07-23 08:25:28 +0000
commit90d14975bb3ddf69d631b8238ecaaf96812e2b9b (patch)
treefc3485111fb1e1e3531453e15093d5256de0a28d
parent54285fa7ac9cf3af85d07af4b9f8cc6bf0d01cac (diff)
Add aws-iot-device-embedded-c support to crosssdk
AWS SDK is included to AGL cross SDK, it allows users to use AWS SDK during appropriate (working with cloud) AGL application development. v2: resubmit Library mbedTLS has been added to AGL SDK, because it is required for AWS SDK. Bug-AGL: SPEC-3480 Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com> Change-Id: I015ecad01970bebad8f25b8c5024cbe74c7fd78c Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-platform/images/agl-demo-platform-crosssdk.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index 35883aea..641befa0 100644
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -40,6 +40,16 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
# memory issue.
TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
-# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
-# other users of Azure sdk.
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy
+# and other users of Azure sdk.
TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"
+
+# Add mbedTLS to support building aws-iot-device-sdk-embedded-c
+TOOLCHAIN_TARGET_TASK += "mbedtls"
+
+# Add aws-iot-device-embedded-c sdk to support building agl-service-cloudproxy
+# and other users of AWS sdk.
+# These packages are required to add static library and headers:
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
+