summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-14 17:00:23 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-15 23:25:48 +0000
commit198b0ba38aedddd7a1cca2eaf6dcd40414591076 (patch)
tree1c928362a56e261762b0db881ad76058ed1bace2
parentee473ff99bb5ffda3cf2758d3bc693541ada47eb (diff)
Update demo app runtime dependencies
Update runtime dependencies in demo app recipes to match current binding requirements. Bug-AGL: SPEC-3748 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ibaab8d0d2b00f764946ed8472e76a504647b697e
-rw-r--r--recipes-demo/alexa-viewer/alexa-viewer_git.bb1
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb8
-rw-r--r--recipes-demo/launcher/launcher_git.bb2
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb1
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb1
-rw-r--r--recipes-demo/settings/settings_git.bb1
6 files changed, 12 insertions, 2 deletions
diff --git a/recipes-demo/alexa-viewer/alexa-viewer_git.bb b/recipes-demo/alexa-viewer/alexa-viewer_git.bb
index 941c334d..8b4e4faf 100644
--- a/recipes-demo/alexa-viewer/alexa-viewer_git.bb
+++ b/recipes-demo/alexa-viewer/alexa-viewer_git.bb
@@ -32,5 +32,6 @@ RDEPENDS_${PN} = " \
libqtappfw \
libafbwsc \
qlibhomescreen \
+ agl-service-homescreen \
agl-service-voice-high-capabilities \
"
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index 2940378a..2fb000fa 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -9,8 +9,6 @@ DEPENDS = " \
qtbase \
qtdeclarative \
qtquickcontrols2 \
- agl-service-homescreen \
- agl-service-weather \
libqtappfw \
libhomescreen \
libafb-helpers-qt \
@@ -35,4 +33,10 @@ OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel'
RDEPENDS_${PN} += " \
libqtappfw \
+ agl-service-audiomixer \
+ agl-service-bluetooth \
+ agl-service-homescreen \
+ agl-service-network \
+ agl-service-weather \
+ agl-service-voice-high \
"
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
index 1f2117e6..36370708 100644
--- a/recipes-demo/launcher/launcher_git.bb
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -27,3 +27,5 @@ S = "${WORKDIR}/git/"
inherit qmake5 systemd pkgconfig aglwgt
PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+RDEPENDS_${PN} = "agl-service-homescreen"
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index 17def6f8..a37838c2 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -24,6 +24,7 @@ RDEPENDS_${PN} += " \
openjtalk \
gstreamer1.0 \
ondemandnavi-config \
+ agl-service-navigation \
"
RPROVIDES_${PN} = "virtual/navigation"
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index 14e5eae3..0dc09411 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -33,5 +33,6 @@ RDEPENDS_${PN} += " \
qtlocation \
ondemandnavi-config \
agl-service-navigation \
+ agl-service-signal-composer \
libqtappfw \
"
diff --git a/recipes-demo/settings/settings_git.bb b/recipes-demo/settings/settings_git.bb
index 491517b7..b3198b28 100644
--- a/recipes-demo/settings/settings_git.bb
+++ b/recipes-demo/settings/settings_git.bb
@@ -26,5 +26,6 @@ RDEPENDS_${PN} += " \
qt-qrcode \
agl-service-bluetooth \
agl-service-network \
+ agl-service-voice-high \
libqtappfw \
"