summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Shamanin <andrei.shamanin@orioninc.com>2020-07-07 14:31:49 +0300
committerAndrey Shamanin <andrei.shamanin@orioninc.com>2020-07-09 16:15:41 +0300
commit3f5c8fe94111312e3186cbf0d5c8c06d4e344ecd (patch)
treee9d73ec922c9ea2e24c3613cc6f0f039eb10ed18
parentee233e708a0b5308a4a3468a60d03358a9281e7a (diff)
Add aws-iot-device-embedded-c support to crosssdk
AWS SDK is included to AGL cross SDK, it allows users to use AWS SDK during appropriate (working with cloud) AGL application development. Bug-AGL: SPEC-3480 Signed-off-by: Andrey Shamanin <andrei.shamanin@orioninc.com> Change-Id: I2494396bec28156ba2e732515f9ab2b61a8f71f7
-rw-r--r--recipes-platform/images/agl-demo-platform-crosssdk.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/recipes-platform/images/agl-demo-platform-crosssdk.bb b/recipes-platform/images/agl-demo-platform-crosssdk.bb
index 35883aea..d71eb885 100644
--- a/recipes-platform/images/agl-demo-platform-crosssdk.bb
+++ b/recipes-platform/images/agl-demo-platform-crosssdk.bb
@@ -40,6 +40,13 @@ TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
# memory issue.
TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
-# Add azure-iot-sdk-c to support building agl-service-cloudproxy and
-# other users of Azure sdk.
+# Add azure-iot-sdk-c to support building agl-service-cloudproxy
+# and other users of Azure sdk.
TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"
+
+# Add aws-iot-device-embedded-c sdk to support building agl-service-cloudproxy
+# and other users of AWS sdk.
+# These packages are required to add static library and headers:
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
+TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
+