summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-23 12:36:38 -0400
committerScott Murray <scott.murray@konsulko.com>2020-09-23 12:36:38 -0400
commita8f83b423cf7015304b79a759abd474444003937 (patch)
treed5f673098b4ac7f0f56fd37fd3a171bac61fc89f
parent3091e2b5019a19318d64dc5656271166ce0cbc54 (diff)
agl-service-cloudproxy: fix recipe branch/revision
Change branch and SRCREV in agl-service-cloudproxy recipe to use AGL_BRANCH and AGL_APP_REVISION variables like all other upstream service bindings. This will pick up: 329d8ba Add tests for cloudproxy service Also reordered some things in the recipe to match OE guidelines. Bug-AGL: SPEC-3485 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ica02bd4a34c41490105b2e88f085b0d6c163c615
-rw-r--r--recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb b/recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb
index dcfb3844..588e86f4 100644
--- a/recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb
+++ b/recipes-apis/agl-service-cloudproxy/agl-service-cloudproxy_git.bb
@@ -5,20 +5,19 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=133bb7bd14f18c4f134e819619b3f09a"
-inherit cmake aglwgt pkgconfig
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https"
-
-SRCREV = "0cecffd4565b52bd8d200f6bc9f4144f244a6515"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-cloudproxy;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git/"
DEPENDS = "azure-iot-sdk-c glib-2.0"
-RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+inherit cmake aglwgt pkgconfig
-#azure include files
+# Azure include files
CXXFLAGS_prepend += "-I${STAGING_INCDIR}/azureiot"
+RDEPENDS_${PN} += "azure-iot-sdk-c azure-c-shared-utility"
+
BBCLASSEXTEND = "native nativesdk"