summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnaud Ferraris <arnaud.ferraris@collabora.com>2021-12-07 19:15:58 +0100
committerArnaud Ferraris <arnaud.ferraris@collabora.com>2021-12-21 09:02:51 +0100
commita88b3b1779ea71960a3048ec9a0f5fa32f52ed9c (patch)
tree8724b7ca5896085eec48c2231c623a6a8a2cd257
parent864ca525d2edd914d58077bec6faa963b704258a (diff)
recipes-demo: restore launcher application
While launcher hasn't been merged into homescreen, we should restore it as a default application. Bug-AGL: SPEC-4159 Signed-off-by: Arnaud Ferraris <arnaud.ferraris@collabora.com> Change-Id: I772142beec717b0f244b1c1a9c128baf843827fd
-rw-r--r--recipes-demo/launcher/files/launcher.service12
-rw-r--r--recipes-demo/launcher/launcher_git.bb47
2 files changed, 59 insertions, 0 deletions
diff --git a/recipes-demo/launcher/files/launcher.service b/recipes-demo/launcher/files/launcher.service
new file mode 100644
index 00000000..6170f60d
--- /dev/null
+++ b/recipes-demo/launcher/files/launcher.service
@@ -0,0 +1,12 @@
+[Unit]
+Name=AGL Launcher
+Requires=homescreen.service
+After=homescreen.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/launcher
+Restart=on-failure
+
+[Install]
+WantedBy=agl-session.target
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
new file mode 100644
index 00000000..e6773415
--- /dev/null
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -0,0 +1,47 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ wayland-native \
+ wayland \
+ qtwayland \
+ qtwayland-native \
+ agl-compositor \
+ json-c \
+ applaunchd \
+"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
+ file://launcher.service \
+ "
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 systemd pkgconfig
+
+PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+do_install:append() {
+ install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+ install -m0644 ${WORKDIR}/launcher.service ${D}${systemd_user_unitdir}/launcher.service
+ ln -s ../launcher.service ${D}${systemd_user_unitdir}/agl-session.target.wants/launcher.service
+}
+
+FILES:${PN} += " ${systemd_user_unitdir}"
+
+RDEPENDS:${PN} += " \
+ applaunchd \
+ homescreen \
+"