summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-06 17:49:59 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-06 17:53:57 -0400
commitc5c43ada3a831e3194578830522713edfb482ca7 (patch)
tree9e95c10f34535051c605e0fd7f6978c131264585
parentaf8b5d850e4da041f1fa1bb56a63ef7b6cf88a83 (diff)
Rename agl-cluster-demo-support feature
Rename agl-cluster-demo-support feature to agl-demo-cluster-support to make it clearer that it relates to the agl-demo-platform image. Bug-AGL: SPEC-4425 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3a29f6507a55bb4ec5ae5ecb70e10bb910759196
-rw-r--r--recipes-connectivity/connman/connman_agldemo.inc2
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb2
-rw-r--r--templates/feature/agl-cluster-demo-support/50_local.conf.inc1
-rw-r--r--templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md15
-rw-r--r--templates/feature/agl-demo-cluster-support/50_local.conf.inc1
-rw-r--r--templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md17
-rw-r--r--templates/feature/agl-demo-cluster-support/included.dep (renamed from templates/feature/agl-cluster-demo-support/included.dep)0
7 files changed, 20 insertions, 18 deletions
diff --git a/recipes-connectivity/connman/connman_agldemo.inc b/recipes-connectivity/connman/connman_agldemo.inc
index 5b732ae5..7b736ec6 100644
--- a/recipes-connectivity/connman/connman_agldemo.inc
+++ b/recipes-connectivity/connman/connman_agldemo.inc
@@ -1,6 +1,6 @@
do_install:append() {
# Need to ignore eth1 in cluster demo setup
- if ${@bb.utils.contains('AGL_FEATURES', 'agl-cluster-demo-support', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('AGL_FEATURES', 'agl-demo-cluster-support', 'true', 'false', d)}; then
sed -i 's/^\(NetworkInterfaceBlacklist=.*\)/\1,eth1/' ${D}${sysconfdir}/connman/main.conf
fi
}
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index 9c4553f2..fdebd24a 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -39,7 +39,7 @@ CLUSTER_SUPPORT_PACKAGES = " \
tbtnavi \
cluster-demo-network-config \
"
-CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
+CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-cluster-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
# Hook for demo platform configuration
# ATM used for:
diff --git a/templates/feature/agl-cluster-demo-support/50_local.conf.inc b/templates/feature/agl-cluster-demo-support/50_local.conf.inc
deleted file mode 100644
index 0be5431b..00000000
--- a/templates/feature/agl-cluster-demo-support/50_local.conf.inc
+++ /dev/null
@@ -1 +0,0 @@
-AGL_FEATURES:append = " agl-cluster-demo-support"
diff --git a/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md b/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md
deleted file mode 100644
index bdb04f0b..00000000
--- a/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-cluster-demo-support
-authors: Scott Murray <scott.murray@konsulko.com>
----
-
-### Feature agl-cluster-demo-support
-
-*Description is missing - please complete file meta-agl-demo/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md*
-
-#### Dependent features pulled by agl-cluster-demo-support
-
-The following features are pulled:
-
-* agl-gstrecorder
-
diff --git a/templates/feature/agl-demo-cluster-support/50_local.conf.inc b/templates/feature/agl-demo-cluster-support/50_local.conf.inc
new file mode 100644
index 00000000..188d8e8e
--- /dev/null
+++ b/templates/feature/agl-demo-cluster-support/50_local.conf.inc
@@ -0,0 +1 @@
+AGL_FEATURES:append = " agl-demo-cluster-support"
diff --git a/templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md b/templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md
new file mode 100644
index 00000000..a9ff2cfb
--- /dev/null
+++ b/templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md
@@ -0,0 +1,17 @@
+---
+description: Feature agl-demo-cluster-support
+authors: Scott Murray <scott.murray@konsulko.com>
+---
+
+### Feature agl-demo-cluster-support
+
+Enables support for remote navigation display on a connected board running
+the agl-cluster-demo-platform image. The configuration is in large part
+intended for use with the AGL tradeshow demo setup.
+
+#### Dependent features pulled by agl-demo-cluster-support
+
+The following features are pulled:
+
+* agl-weston-remoting
+
diff --git a/templates/feature/agl-cluster-demo-support/included.dep b/templates/feature/agl-demo-cluster-support/included.dep
index 1e9b35fb..1e9b35fb 100644
--- a/templates/feature/agl-cluster-demo-support/included.dep
+++ b/templates/feature/agl-demo-cluster-support/included.dep