summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-02-14 18:22:57 -0500
committerScott Murray <scott.murray@konsulko.com>2022-02-15 22:25:18 +0000
commit191a271822f4747f1c13e71c70d42817e746a1fd (patch)
tree4279cad6c0a5321693943b7514e64feee466d36c
parent1d213f481810d926bd9c39723f592efff1f35e1d (diff)
libqtappfw: enable building mpd based mediaplayer support
Update libqtappfw recipe to pull in libmpdclient dependency for building the reworked mediaplayer support, and also add a RRECOMMENDS definition that pulls in bluez5, connman, and mpd to make the relationship more explicit. The intent is to split the libqtappfw-X libraries into separate packages with some follow-on rework and have these dependencies be more fine-grained at that point. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: If7fcd57dab89a22dfee81017d0411854b1f16bda
-rw-r--r--recipes-demo/libqtappfw/libqtappfw_git.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes-demo/libqtappfw/libqtappfw_git.bb b/recipes-demo/libqtappfw/libqtappfw_git.bb
index cc36e718..43d9e8a6 100644
--- a/recipes-demo/libqtappfw/libqtappfw_git.bb
+++ b/recipes-demo/libqtappfw/libqtappfw_git.bb
@@ -6,7 +6,14 @@ SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib connman-glib"
+DEPENDS = " \
+ qtbase \
+ qtdeclarative \
+ glib-2.0 \
+ bluez-glib \
+ connman-glib \
+ libmpdclient \
+"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "5ef90db242ad29c9772f2237b477c58ef65545c7"
@@ -17,4 +24,6 @@ PV = "2.0+git${SRCPV}"
inherit cmake_qt5 pkgconfig
+RRECOMMENDS:${PN} += "bluez5 connman mpd"
+
BBCLASSEXTEND = "nativesdk"