aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBocklage, Jens <Jens_Bocklage@mentor.com>2016-06-30 13:59:02 +0200
committerBocklage, Jens <Jens_Bocklage@mentor.com>2016-06-30 15:28:33 +0200
commit0b5dde065fc42a8efa898a2e766d4b484acb28d2 (patch)
treea81ae131e52a131953fa54fe4c1e5013804c9733
parentae65602b0c690fba81ba79b718dfcf5bb83d5d84 (diff)
[homescreen] Add bitbake recipe for Home Screen app
This bitbake recipe builds the Home Screen application. In addition a sample application that shows the functionality of the status bar. The sample application SampleAppTimeDate shows the current time in the Home Screen status bar. Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
-rw-r--r--recipes-demo-hmi/HomeScreen/HomeScreen.bb31
-rw-r--r--recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb31
2 files changed, 31 insertions, 31 deletions
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen.bb b/recipes-demo-hmi/HomeScreen/HomeScreen.bb
deleted file mode 100644
index 681b84f0..00000000
--- a/recipes-demo-hmi/HomeScreen/HomeScreen.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "${PN} for the AGL Demo Platform"
-DESCRIPTION = "${PN} app"
-HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/${PN}"
-
-SECTION = "apps"
-
-# To be revised once sourcecode lands
-# LICENSE = "xyz"
-# Dummy MPL-2.0
-LICENSE = "MPL-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
-
-
-SRC_URI = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/${PN};protocol=http"
-SRCREV = "AUTOINC"
-
-# custom configure and install as these are just qml files
-
-# we work in the git checkout ...
-S = "${WORKDIR}/git"
-
-do_configure() {
- true
-}
-
-# empty folder for now
-do_install() {
- mkdir -p ${D}/opt/AGL/${PN}/
-}
-
-FILES_${PN} = "/opt/AGL/${PN}/"
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb b/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb
new file mode 100644
index 00000000..42a61d10
--- /dev/null
+++ b/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
+HOMEPAGE = "https://wiki.automotivelinux.org/homescreen"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "r1"
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+DEPENDS = "qtbase"
+
+LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV = "cf47f13164830e5b153db006cc55c3cf126d8d8c"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+
+
+do_compile_prepend(){
+ PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
+ export PATH
+}
+
+do_install() {
+ install -d ${D}/opt/AGL/${PN}
+ install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
+ install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
+}
+
+FILES_${PN} += "/opt/AGL/${PN}/"
+FILES_${PN}-dbg += "/opt/AGL/${PN}/.debug"
+