aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-06-23 13:07:38 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-07-06 21:02:19 +0200
commit18e358f3aa4abe46910471f120339060693d8537 (patch)
treea2dab9f762ca9d748c4e83bb929da81a3e0b5fa9
parentc4995e90c94cfe2d465a558ee74720b4d8afc62e (diff)
meta-agl-demo: add recipes-most
This patch adds the recipes needed to copy the applicatons from the most-can-demo-bin folder of the staging area to and the /home/root directory. It is needed to run the MOST video demo and the CAN application on the agl-demo-platform. v2: Changed folder recipes-demo-hmi as per discussion in gerrit (jsmoeller) Change-Id: I5de98416a4d32b794552a2e42d4e95129704db47 Signed-off-by: Christian Gromm <christian.gromm@microchip.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb23
-rw-r--r--recipes-demo-hmi/ALS2016-demo/vod_0.1.bb30
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb b/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
new file mode 100644
index 00000000..1cca96cc
--- /dev/null
+++ b/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "CAN-LIN Application"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r0"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
+
+S = "${WORKDIR}/git"
+SRCREV = "cd6e46d117934139efdf5fac33fbeb59b66e45b6"
+
+do_configure() {
+ echo ""
+}
+
+do_compile() {
+ echo ""
+}
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 0644 ${S}/OptoLyzerMoccaApp ${D}${bindir}
+}
+
diff --git a/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb b/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb
new file mode 100644
index 00000000..670e680e
--- /dev/null
+++ b/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Video on demand"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r0"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
+
+S = "${WORKDIR}/git"
+SRCREV = "cd6e46d117934139efdf5fac33fbeb59b66e45b6"
+
+do_configure() {
+ echo ""
+}
+
+do_compile() {
+ echo ""
+}
+
+do_install() {
+ install -m 0755 -d ${D}${bindir} ${D}${base_dir}/home/root ${D}${docdir}/video-on-demand
+ install -m 0644 ${S}/NetworkManager ${D}${bindir}
+ install -m 0644 ${S}/VideoOnDemand ${D}${bindir}
+ install -m 0644 ${S}/vod-client ${D}${bindir}
+ install -m 0644 ${S}/config-agl.xml ${D}${base_dir}/home/root
+ install -m 0644 ${S}/i2c-slim-amplifier.script ${D}${base_dir}/home/root
+ install -m 0644 ${S}/i2c-uda1388-v2.script ${D}${base_dir}/home/root
+# install -m 0644 ${WORKDIR}/README.txt ${D}${docdir}/video-on-demand
+}
+FILES_${PN} += "/home/root*"
+