aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBocklage, Jens <Jens_Bocklage@mentor.com>2016-07-06 19:49:45 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-07-10 16:10:58 +0000
commit36dc06d5a521b1baca30bae3199b25aeb91bf9ed (patch)
treebefb2291b89da795e737220280414f9e9d847439
parent1fdfeba3f8b0ef45a392507ad17ab3eadaf1362a (diff)
[homescreen] Add support for color schemes.
Three demo color schemes are included to demonstrate the feature. Also cleaned up the generation of D-Bus interface classes. Signed-off-by: Bocklage, Jens <Jens_Bocklage@mentor.com>
-rw-r--r--recipes-demo-hmi/HomeScreen/HomeScreen_0.1.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.1.bb b/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.1.bb
new file mode 100644
index 00000000..fa3b03d2
--- /dev/null
+++ b/recipes-demo-hmi/HomeScreen/HomeScreen_0.1.1.bb
@@ -0,0 +1,34 @@
+SUMMARY = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application + Home Screen Simulator + SampleAppTimeDate"
+HOMEPAGE = "https://wiki.automotivelinux.org/homescreen"
+LICENSE = "Apache-2.0"
+SECTION = "apps"
+PV = "0.1.1+gitr${SRCPV}"
+PR = "r1"
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+DEPENDS = "qtbase"
+
+LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+SRCREV = "3478f65b39560b333ba189e7d86e2c2cebfc9c7a"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http"
+
+
+do_compile_prepend(){
+ PATH=$PATH:${STAGING_BINDIR_NATIVE}/qt5
+ export PATH
+}
+
+do_install() {
+ install -d ${D}/opt/AGL/${PN}
+ install -m 0755 ${B}/HomeScreen/HomeScreen ${D}/opt/AGL/${PN}/
+ install -m 0755 ${B}/SampleAppTimeDate/SampleAppTimeDate ${D}/opt/AGL/${PN}/
+
+ install -d ${D}/opt/AGL/${PN}/colorschemes
+ cp ${B}/HomeScreen/colorschemes/* ${D}/opt/AGL/${PN}/colorschemes/
+}
+
+FILES_${PN} += "/opt/AGL/${PN}/"
+FILES_${PN}-dbg += "/opt/AGL/${PN}/.debug"
+