aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-13 17:10:40 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-18 14:47:37 +0000
commit4025cc68a1886a7c544628d83e2db534fb521e25 (patch)
treee75107223d14855a31d7481137ffd854ec047995
parent265a7ad644f159221df56d9feecb3bd5eb9cfdfa (diff)
qtwayland-config: remove recipe
Remove qtwayland-config recipe since nothing uses it, rather than rework its RPROVIDES. Bug-AGL: SPEC-5067 Change-Id: Ie6ac95319068f1bed560eb322f2625561bd6db82 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29623 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-qt/qt/qtwayland-config/qtwayland12
-rw-r--r--recipes-qt/qt/qtwayland-config_1.0.0.bb21
2 files changed, 0 insertions, 33 deletions
diff --git a/recipes-qt/qt/qtwayland-config/qtwayland b/recipes-qt/qt/qtwayland-config/qtwayland
deleted file mode 100644
index a371c6c4..00000000
--- a/recipes-qt/qt/qtwayland-config/qtwayland
+++ /dev/null
@@ -1,12 +0,0 @@
-QT_WAYLAND_SHELL_INTEGRATION=@QT_WAYLAND_DEFAULT_SHELL@
-# The following might be necessary when multiple/split surfaces are created.
-# Without this, QtWayland will sometimes maintain the same/old size even if the
-# split surface is destroyed.
-# We keep it disabled by default as it causes an additional repaint of the
-# surface until the compositor sends a configure event to scale the window to
-# the actual area. Typical windows will, by default, have an initial size set
-# by qtwayland when starting-up (without an explicit size specified by the
-# application).
-# Note that QtWayland will only test the presence of the environment variable
-# so it will be enabled even if set to 0
-# QT_WAYLAND_RESIZE_AFTER_SWAP=1
diff --git a/recipes-qt/qt/qtwayland-config_1.0.0.bb b/recipes-qt/qt/qtwayland-config_1.0.0.bb
deleted file mode 100644
index 7c1e99bf..00000000
--- a/recipes-qt/qt/qtwayland-config_1.0.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "QtWayland config file."
-DESCRIPTION = "Config file for qtwayland."
-SECTION = "apps"
-LICENSE = "MIT"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-SRC_URI = "file://qtwayland"
-
-inherit allarch
-
-QTWAYLAND_DEFAULT_SHELL ?= "xdg-shell"
-
-do_compile[noexec] = "1"
-
-do_install () {
- install -D -m 644 ${WORKDIR}/qtwayland ${D}${sysconfdir}/afm/unit.env.d/qtwayland
- sed -i -e 's/@QT_WAYLAND_DEFAULT_SHELL@/${QTWAYLAND_DEFAULT_SHELL}/' ${D}${sysconfdir}/afm/unit.env.d/qtwayland
-}
-
-RPROVIDES:${PN} += "virtual/qtwayland-config"