aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tnikawa <tanikawa.tadao@jp.panasonic.com>2016-06-24 11:11:43 +0900
committerWalt Miner <wminer@linuxfoundation.org>2016-07-05 13:40:24 +0000
commit68c8618ebb5e06694e22043fff57a6a9e02f0c87 (patch)
treeaa838a13ccc77d015ed72f17e059cf3efcca8116
parentd38fa73285a0a4806091ec9ff71940f27882e68a (diff)
Add AGL Demo Suide for ALS 2016
Add AGL Demo Apps for ALS 2016 to be integrated into agl-demo-platform. Change-Id: Iec3706c889c47de40fdee6944bee45d2ce3ebf09 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb36
-rw-r--r--recipes-platform/images/agl-demo-platform.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb b/recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb
new file mode 100644
index 00000000..04d00da0
--- /dev/null
+++ b/recipes-demo-hmi/ALS2016-demo/ALS2016-demo.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Homescreen for the AGL Demonstrator @ ALS2016"
+DESCRIPTION = "Homescreen apps in QML format for the AGL Demonstrator @ ALS2016"
+HOMEPAGE = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/ALS2016"
+
+SECTION = "apps"
+
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/ALS2016;protocol=http"
+SRCREV = "${AUTOREV}"
+
+PV = "1.0+git"
+
+RDEPENDS_${PN} += " \
+ qtmultimedia-qmlplugins \
+ qtquickcontrols-qmlplugins \
+ qtsvg-plugins \
+ "
+
+# custom configure and install as these are just qml files
+
+# we work in the git checkout ...
+S = "${WORKDIR}/git"
+
+do_configure() {
+ ls
+}
+
+# plain copy in own folder for now
+do_install() {
+ mkdir -p ${D}/opt/AGL/ALS2016/
+ cp -ar ./* ${D}/opt/AGL/ALS2016/
+}
+
+FILES_${PN} = "/opt/AGL/"
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index 2089e7a0..4ae985e9 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -17,6 +17,7 @@ IMAGE_INSTALL_append = " \
# add packages for CES2016 demo
IMAGE_INSTALL_append = " \
+ ALS2016-demo \
CES2016-demo \
can-utils iproute2 \
python-curses \