aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2016-05-24 06:26:30 +0700
committerGerrit Code Review <gerrit@172.30.200.200>2016-05-29 10:39:42 +0000
commit83c4a67a5daf437f717dd519b3a85f8a803e9357 (patch)
treebe67d6d29b4f3b5dc6e8878bcaa6a3ca58bb2c5b
parenta4bb343dcb1e25a99952b3e4da887a2658b05734 (diff)
Refactoring code for installation qml libs
- Use ${libdir} instead of hardcoding /usr/lib - Change to use install command for copy files Change-Id: I4506f69c97ad223b94561fd10b97e5a406c4c4d9 Signed-off-by: Phong Tran <tranmanphong@gmail.com>
-rw-r--r--recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb4
-rw-r--r--recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb6
-rw-r--r--recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb6
3 files changed, 8 insertions, 8 deletions
diff --git a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
index c54e28cc..e804113d 100644
--- a/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
+++ b/recipes-automotive/ambdbusaccess/ambdbusaccess_0.1.bb
@@ -17,8 +17,8 @@ RPROVIDES_${PN} = "ambdbusaccess"
inherit qmake5
do_install () {
- mkdir -p ${D}/usr/lib/qt5/qml/Automotive/
- cp ambdbusaccess ${D}/usr/lib/qt5/qml/Automotive/
+ install -d ${D}${libdir}/qt5/qml/Automotive/
+ install -m 0755 ambdbusaccess ${D}${libdir}/qt5/qml/Automotive/
}
FILES_${PN} += "${libdir}/qt5/qml/Automotive/ambdbusaccess"
diff --git a/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb b/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb
index 8058bdbf..7f98fb39 100644
--- a/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb
+++ b/recipes-automotive/climatecontrolplugin/climatecontrolplugin_0.1.bb
@@ -18,9 +18,9 @@ RDEPENDS_${PN} = "automotive-message-broker ambdbusaccess"
inherit qmake5
do_install () {
- mkdir -p ${D}/usr/lib/qt5/qml/Automotive/ClimateControl/
- cp libClimateControl.so ${D}/usr/lib/qt5/qml/Automotive/ClimateControl/
- cp qmldir ${D}/usr/lib/qt5/qml/Automotive/ClimateControl/
+ install -d ${D}${libdir}/qt5/qml/Automotive/ClimateControl/
+ install -m 0755 libClimateControl.so ${D}${libdir}/qt5/qml/Automotive/ClimateControl/
+ install -m 0644 qmldir ${D}${libdir}/qt5/qml/Automotive/ClimateControl/
}
FILES_${PN} += "${libdir}/qt5/qml/Automotive/ClimateControl/libClimateControl.so \
diff --git a/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb b/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
index 1f9dc6d0..dbeda2d1 100644
--- a/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
+++ b/recipes-qt/qml-execscript-plugin/qml-execscript-plugin_1.0.bb
@@ -15,9 +15,9 @@ EXTRA_OECONF = "--with-moc-dir=${STAGING_BINDIR_NATIVE}/qt5"
QML_LIBDIR = "${libdir}/qt5/qml"
do_install() {
- mkdir -p ${D}/usr/lib/qt5/qml/execScript/
- cp execScript/*.so ${D}/usr/lib/qt5/qml/execScript/
- cp ../git/execScript/qmldir ${D}/usr/lib/qt5/qml/execScript/
+ install -d ${D}${libdir}/qt5/qml/execScript/
+ install -m 0755 execScript/*.so ${D}${libdir}/qt5/qml/execScript/
+ install -m 0644 ../git/execScript/qmldir ${D}${libdir}/qt5/qml/execScript/
}
FILES_${PN} += "${QML_LIBDIR}/execScript/libexecscriptplugin.so"