aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-02-10 19:43:55 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-02-10 13:02:11 +0000
commitaf16a40f5c45cb34c1bc7efbe9700d29191d81bf (patch)
tree84b38e7bd30a20a3a4dd42b68db3d5db8143982e
parentd7dc839ad442145e364fca6f9cfd7938fe0e2db9 (diff)
Add package group and bitbake target for Quality Assurance
New packagegroup and bitbake target are added which includes utilities for testing distribution. It is assumed to be used in the Quality Assurance of AGL Distro. New package group: packagegroup-agl-demo-platform-qa New target: agl-demo-platform-qa Change-Id: I96efde8348037821a6dfcd653e9fcbc87408f183 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--conf/conf-notes.txt2
-rw-r--r--recipes-platform/images/agl-demo-platform-qa.bb11
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb15
-rw-r--r--templates/intel-corei7-64/conf/conf-notes.txt2
-rw-r--r--templates/qemux86-64/conf/conf-notes.txt2
-rw-r--r--templates/qemux86/conf/conf-notes.txt2
6 files changed, 34 insertions, 0 deletions
diff --git a/conf/conf-notes.txt b/conf/conf-notes.txt
index 502690dc..bdee76b8 100644
--- a/conf/conf-notes.txt
+++ b/conf/conf-notes.txt
@@ -1,5 +1,7 @@
Common targets are:
agl-image-ivi
agl-image-ivi-crosssdk
+ agl-image-ivi-qa
agl-demo-platform
agl-demo-platform-crosssdk
+ agl-demo-platform-qa
diff --git a/recipes-platform/images/agl-demo-platform-qa.bb b/recipes-platform/images/agl-demo-platform-qa.bb
new file mode 100644
index 00000000..bec5e870
--- /dev/null
+++ b/recipes-platform/images/agl-demo-platform-qa.bb
@@ -0,0 +1,11 @@
+SUMMARY = "A full set of AGL Distribution for testing as Quality Assurance"
+
+DESCRIPTION = "A full set of AGL Distribution. This image also has additional \
+packages (e.g. commandline tools) for Quality Assurance(QA)."
+
+require agl-demo-platform.bb
+
+IMAGE_INSTALL_append = " \
+ packagegroup-ivi-common-test \
+ packagegroup-agl-demo-platform-qa \
+ "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb
new file mode 100644
index 00000000..739f859b
--- /dev/null
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb
@@ -0,0 +1,15 @@
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform includes utilities for testing distribution as Quality Assurance"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-demo-platform-qa \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/templates/intel-corei7-64/conf/conf-notes.txt b/templates/intel-corei7-64/conf/conf-notes.txt
index 502690dc..bdee76b8 100644
--- a/templates/intel-corei7-64/conf/conf-notes.txt
+++ b/templates/intel-corei7-64/conf/conf-notes.txt
@@ -1,5 +1,7 @@
Common targets are:
agl-image-ivi
agl-image-ivi-crosssdk
+ agl-image-ivi-qa
agl-demo-platform
agl-demo-platform-crosssdk
+ agl-demo-platform-qa
diff --git a/templates/qemux86-64/conf/conf-notes.txt b/templates/qemux86-64/conf/conf-notes.txt
index 502690dc..bdee76b8 100644
--- a/templates/qemux86-64/conf/conf-notes.txt
+++ b/templates/qemux86-64/conf/conf-notes.txt
@@ -1,5 +1,7 @@
Common targets are:
agl-image-ivi
agl-image-ivi-crosssdk
+ agl-image-ivi-qa
agl-demo-platform
agl-demo-platform-crosssdk
+ agl-demo-platform-qa
diff --git a/templates/qemux86/conf/conf-notes.txt b/templates/qemux86/conf/conf-notes.txt
index 502690dc..bdee76b8 100644
--- a/templates/qemux86/conf/conf-notes.txt
+++ b/templates/qemux86/conf/conf-notes.txt
@@ -1,5 +1,7 @@
Common targets are:
agl-image-ivi
agl-image-ivi-crosssdk
+ agl-image-ivi-qa
agl-demo-platform
agl-demo-platform-crosssdk
+ agl-demo-platform-qa