aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:25:44 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:26:16 +0200
commitc893ae9b7e61a833899b181e0017ee2cfab8b97e (patch)
tree7fda40eb53136b8ea5822c83adf16a3b172b87f4
parenta27f579b5039e237b7f3b489ac551d0e40f2f980 (diff)
Changes for building meta-agl-demo with YP 2.1.1 'krogoth'
Update meta-agl-demo for YP 2.1 'krogoth' Notable changes: - update qtbase wrt packageconfig flags - qtwayland needs the patches checked/ported - remove qtwayland examples from packagegroup-agl-appfw-native TODO: - Check graphic driver stack (mesa, wayland, weston, qtbase, qtwayland et al.) - Check wrt SPEC-237 - port patches for qtwayland - check where qtwayland-examples is gone and either remove or re-add Change-Id: Ib14f1230d0fdc84f82af3e875460c0269faec652 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb5
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend12
-rw-r--r--recipes-qt/qt5/qtwayland_%.bbappend3
3 files changed, 13 insertions, 7 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
index abc62d80..1fe2579f 100644
--- a/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
+++ b/recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
@@ -31,12 +31,15 @@ RDEPENDS_${PN} += "\
qtquick1-plugins \
qtquick1-tools \
qtwayland \
- qtwayland-examples \
qtwayland-plugins \
qtwayland-tools \
qtgraphicaleffects-qmlplugins \
qml-execscript-plugin \
"
+RDEPENDS_${PN}_checkforkrogoth += "\
+ qtwayland-examples \
+ "
+
# qtwebkit
# qtwebkit-qmlplugins
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index ebca5c8e..026e76fe 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,13 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = "\
- file://0001-Force-qdbus-to-make-introspect-for-every-findMetaObj.patch \
- "
-
DEPENDS_append_koelsch = " libegl"
DEPENDS_append_porter = " libegl"
PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
-PACKAGECONFIG_append = " icu accessibility"
+PACKAGECONFIG_append = " icu accessibility eglfs"
+PACKAGECONFIG_append_rpi = " fontconfig"
+
+EXTRA_OECONF_append = ""
+
-EXTRA_OECONF_append = " -qpa wayland"
+PACKAGECONFIG[gles2]="-opengl es2 -eglfs,,virtual/libgles2 virtual/egl"
diff --git a/recipes-qt/qt5/qtwayland_%.bbappend b/recipes-qt/qt5/qtwayland_%.bbappend
index b61b121c..ed9e3749 100644
--- a/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/recipes-qt/qt5/qtwayland_%.bbappend
@@ -22,10 +22,13 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
+ "
+SRC_URI_append_checkforkrogoth = "\
file://disable_xcomposite_egl_qt_wayland_client_buffer_integration.patch \
file://0001-Implement-initial-IVI-shell-support-with-shell-integ.patch \
file://0002-Fix-multiple-QWindow.patch \
"
+
DEPENDS_append_koelsch = " libegl gles-user-module"
DEPENDS_append_porter = " libegl gles-user-module"