aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>2016-05-05 13:56:21 -0300
committerGerrit Code Review <gerrit@172.30.200.200>2016-05-06 13:31:46 +0000
commitee55488e1f47e03e608594a8d7273648d3da389d (patch)
tree72bfa554ed74a3c8094b9945cae09edfe33dfe27
parent27d10e87ed68653f010df94a699f80d4811ff007 (diff)
Provide patched Wayland-IVI-Extension to work with patched Weston from meta-agl-demo.
This change adds support for Wayland IVI Extension 1.9.1 (latest stable release) to work against the patched weston from meta-agl-demo. It should not be used when using a stock/unpatched weston. Wayland-IVI-Extension provides an additional shell plugin for IVI-Shell, along with command-line tools and demonstration applications. More info at http://projects.genivi.org/wayland-ivi-extension. Change-Id: Id74c164eace0cb54d367eda743982bb8baf5d523 Signed-off-by: Andre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
new file mode 100644
index 00000000..da97895a
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
@@ -0,0 +1,28 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+ -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+ "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+ -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+ "
+
+PACKAGECONFIG ??= "test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
+SRC_URI_append = "\
+ file://0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch \
+ file://cmake-find-gtest.patch \
+ file://test-path.patch \
+ "
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+ ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+ ${libdir}/${PN}/test/ivi-input-api-test \
+ "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"