aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-08-02 14:51:34 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-08-03 20:39:01 +0000
commitfac2d5b645decc05356eede37b04e513a9961569 (patch)
treee6e7784db3887c4ed739eee3bee39096ab989f61
parent1ea0cef6934ccadc36395b60d8b8d58d69016e28 (diff)
recipes-demo-hmi: fix file permissions
This patch makes the pre-compiled demo applications executable by assiging the suitable permissions when installing them on the rootfs. Change-Id: I0145d1e983d60e6312c40cc0d3e2c4aa3257b44e Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
-rw-r--r--recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb2
-rw-r--r--recipes-demo-hmi/ALS2016-demo/vod_0.1.bb6
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb b/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
index 1cca96cc..d94d3982 100644
--- a/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
+++ b/recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
@@ -18,6 +18,6 @@ do_compile() {
do_install() {
install -m 0755 -d ${D}${bindir}
- install -m 0644 ${S}/OptoLyzerMoccaApp ${D}${bindir}
+ install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
}
diff --git a/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb b/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb
index 670e680e..8e3cbf33 100644
--- a/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb
+++ b/recipes-demo-hmi/ALS2016-demo/vod_0.1.bb
@@ -18,9 +18,9 @@ do_compile() {
do_install() {
install -m 0755 -d ${D}${bindir} ${D}${base_dir}/home/root ${D}${docdir}/video-on-demand
- install -m 0644 ${S}/NetworkManager ${D}${bindir}
- install -m 0644 ${S}/VideoOnDemand ${D}${bindir}
- install -m 0644 ${S}/vod-client ${D}${bindir}
+ install -m 0755 ${S}/NetworkManager ${D}${bindir}
+ install -m 0755 ${S}/VideoOnDemand ${D}${bindir}
+ install -m 0755 ${S}/vod-client ${D}${bindir}
install -m 0644 ${S}/config-agl.xml ${D}${base_dir}/home/root
install -m 0644 ${S}/i2c-slim-amplifier.script ${D}${base_dir}/home/root
install -m 0644 ${S}/i2c-uda1388-v2.script ${D}${base_dir}/home/root