aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-09-15 20:01:43 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-09-15 20:05:19 +0900
commitfaf241c43abeda228789dd26417cea1bfbf900bb (patch)
tree8220d16517ec4669bea40f3c063ebec7c33975d2
parent1285cbf5034408a3ab7225c3b0aeddc58f72ddc3 (diff)
Fix configuration of building Qt5
This patch set configuration of Qt5 as follows: - To set 'wayland-egl' as default of platform plugins - To remove eglfs because AGL don't use it Change-Id: Ia1084173a65870c254ed1a7e3584ad0a8a1524f9 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index 026e76fe..d302780f 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -3,11 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
DEPENDS_append_koelsch = " libegl"
DEPENDS_append_porter = " libegl"
+PACKAGECONFIG_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
-PACKAGECONFIG_append = " icu accessibility eglfs"
+PACKAGECONFIG_append = " ${PACKAGECONFIG_WAYLAND} icu accessibility"
PACKAGECONFIG_append_rpi = " fontconfig"
EXTRA_OECONF_append = ""
-
-PACKAGECONFIG[gles2]="-opengl es2 -eglfs,,virtual/libgles2 virtual/egl"
+# '-qpa wayland-egl' set wayland-egl as default of platform plagins
+PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"