summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-07 16:12:25 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-06 14:32:43 -0400
commitfa8b62e148ec1f2be0494d6f899940913d49704f (patch)
treef96d057ef4744c5b45c61ac33ffbf340a122dc0c
parent074e2c5eb63cd7dafd9d48326c8fadb8da30e9b2 (diff)
Update vehicle signal using app recipes
Update the recipes for the Qt demo applications that were previously using signal-composer either directly or indirectly to work with the new VehicleSignals API in libqtappfw. For most of them this means updating their SRCREV to pick up the application changes, and installing the new configuration file and associated JSON web token file for KUKSA.val authorization. At present all the apps are using one of the default read-write tokens from the KUKSA.val install, but ideally this will end up migrated to app specific tokens with appropriate permissions JSON down the road, potentially obtained via OAuth or similar mechanism. Additionally, the tbtnavi recipe has been updated to install a systemd unit to start it at boot. Bug-AGL: SPEC-4409, SPEC-4426 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I46be098fc31be02852e7888ba0ffd14674efa12b
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.conf3
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.token1
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb13
-rw-r--r--recipes-demo/dashboard/dashboard/dashboard.conf2
-rw-r--r--recipes-demo/dashboard/dashboard/dashboard.token1
-rw-r--r--recipes-demo/dashboard/dashboard_git.bb21
-rw-r--r--recipes-demo/homescreen/files/homescreen.conf2
-rw-r--r--recipes-demo/homescreen/files/homescreen.token1
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb15
-rw-r--r--recipes-demo/hvac/hvac/hvac.conf2
-rw-r--r--recipes-demo/hvac/hvac/hvac.token1
-rw-r--r--recipes-demo/hvac/hvac_git.bb20
-rw-r--r--recipes-demo/mediaplayer/mediaplayer/mediaplayer.conf2
-rw-r--r--recipes-demo/mediaplayer/mediaplayer/mediaplayer.token1
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb20
-rw-r--r--recipes-demo/navigation/ondemandnavi/navigation.conf2
-rw-r--r--recipes-demo/navigation/ondemandnavi/navigation.token1
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb20
-rw-r--r--recipes-demo/navigation/tbtnavi/tbtnavi.conf2
-rw-r--r--recipes-demo/navigation/tbtnavi/tbtnavi.service11
-rw-r--r--recipes-demo/navigation/tbtnavi/tbtnavi.token1
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb29
22 files changed, 158 insertions, 13 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.conf b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.conf
new file mode 100644
index 00000000..b24c64e2
--- /dev/null
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.conf
@@ -0,0 +1,3 @@
+[vis-client]
+server = "192.168.20.93"
+authorization = "/etc/xdg/AGL/cluster-dashboard/cluster-dashboard.token"
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.token b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard/cluster-dashboard.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index b00f1ece..cfe26983 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -19,8 +19,10 @@ PV = "1.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-dashboard;protocol=https;branch=${AGL_BRANCH} \
file://cluster-dashboard.service \
+ file://cluster-dashboard.conf \
+ file://cluster-dashboard.token \
"
-SRCREV = "00fa784cdb2570f742511820b885b1c3e18b6d01"
+SRCREV = "c5115f91d0bf432b3dca32c652bd6fc330b6d7d5"
S = "${WORKDIR}/git"
@@ -30,6 +32,14 @@ do_install:append() {
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
ln -s ../${BPN}.service ${D}${systemd_user_unitdir}/agl-session.target.wants/${BPN}.service
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
+ install -m 0644 ${WORKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
FILES:${PN} += " ${systemd_user_unitdir}"
@@ -43,4 +53,5 @@ RDEPENDS:${PN} += " \
qtquickcontrols2-qmlplugins \
qtgraphicaleffects-qmlplugins \
qtsvg-plugins \
+ kuksa-val-client-certificates \
"
diff --git a/recipes-demo/dashboard/dashboard/dashboard.conf b/recipes-demo/dashboard/dashboard/dashboard.conf
new file mode 100644
index 00000000..23695db3
--- /dev/null
+++ b/recipes-demo/dashboard/dashboard/dashboard.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/dashboard/dashboard.token"
diff --git a/recipes-demo/dashboard/dashboard/dashboard.token b/recipes-demo/dashboard/dashboard/dashboard.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/dashboard/dashboard/dashboard.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/dashboard/dashboard_git.bb b/recipes-demo/dashboard/dashboard_git.bb
index 509b68b2..9f5dba83 100644
--- a/recipes-demo/dashboard/dashboard_git.bb
+++ b/recipes-demo/dashboard/dashboard_git.bb
@@ -9,17 +9,34 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qttools-native \
qtquickcontrols2 \
+ libqtappfw \
"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "3fc84a0a674fa532f6aded100cf2beb3d0cf1f83"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/dashboard;protocol=https;branch=${AGL_BRANCH} \
+ file://dashboard.conf \
+ file://dashboard.token \
+"
+SRCREV = "4efe67714e60e2ab86acf1edee500373f6820954"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/dashboard
+ install -m 0644 ${WORKDIR}/dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/homescreen/files/homescreen.conf b/recipes-demo/homescreen/files/homescreen.conf
new file mode 100644
index 00000000..3ad29f51
--- /dev/null
+++ b/recipes-demo/homescreen/files/homescreen.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/homescreen/homescreen.token"
diff --git a/recipes-demo/homescreen/files/homescreen.token b/recipes-demo/homescreen/files/homescreen.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/homescreen/files/homescreen.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index d21711c8..c8f5eee6 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -22,8 +22,10 @@ PV = "1.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
file://homescreen.service \
+ file://homescreen.conf \
+ file://homescreen.token \
"
-SRCREV = "c35327b02a28a83536450a664326d183662e89e1"
+SRCREV = "e490ff1e1e31b4a837cb8063f7346dc65ffe073e"
S = "${WORKDIR}/git"
@@ -37,6 +39,17 @@ do_install:append() {
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+ install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
}
FILES:${PN} += " ${systemd_user_unitdir}"
diff --git a/recipes-demo/hvac/hvac/hvac.conf b/recipes-demo/hvac/hvac/hvac.conf
new file mode 100644
index 00000000..4a4bb717
--- /dev/null
+++ b/recipes-demo/hvac/hvac/hvac.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/hvac/hvac.token"
diff --git a/recipes-demo/hvac/hvac/hvac.token b/recipes-demo/hvac/hvac/hvac.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/hvac/hvac/hvac.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
index c518708c..8b4b090d 100644
--- a/recipes-demo/hvac/hvac_git.bb
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -16,13 +16,29 @@ DEPENDS = " \
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "c173b5b5fbdb9013304ad62e0dc8f8bb9a072e7d"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=https;branch=${AGL_BRANCH} \
+ file://hvac.conf \
+ file://hvac.token \
+"
+SRCREV = "d37674bb6dbb5ceb15c650a0344b0caf624963bc"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/hvac
+ install -m 0644 ${WORKDIR}/hvac.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/mediaplayer/mediaplayer/mediaplayer.conf b/recipes-demo/mediaplayer/mediaplayer/mediaplayer.conf
new file mode 100644
index 00000000..bc9e0d83
--- /dev/null
+++ b/recipes-demo/mediaplayer/mediaplayer/mediaplayer.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/mediaplayer/mediaplayer.token"
diff --git a/recipes-demo/mediaplayer/mediaplayer/mediaplayer.token b/recipes-demo/mediaplayer/mediaplayer/mediaplayer.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/mediaplayer/mediaplayer/mediaplayer.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index aca107b3..897099af 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -10,13 +10,29 @@ DEPENDS = "qtquickcontrols2 libqtappfw"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "d53efa6bca224f2c6bec8e7b14b1dff7f12a2d03"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH} \
+ file://mediaplayer.conf \
+ file://mediaplayer.token \
+"
+SRCREV = "9c7c1d105faeb57a5b79578318c5731d252c5414"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/mediaplayer
+ install -m 0644 ${WORKDIR}/mediaplayer.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += "libqtappfw mpd"
diff --git a/recipes-demo/navigation/ondemandnavi/navigation.conf b/recipes-demo/navigation/ondemandnavi/navigation.conf
new file mode 100644
index 00000000..fca29cdf
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi/navigation.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/navigation/navigation.token"
diff --git a/recipes-demo/navigation/ondemandnavi/navigation.token b/recipes-demo/navigation/ondemandnavi/navigation.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi/navigation.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index c89ddebb..da198025 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -10,13 +10,29 @@ DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "1593664d2f17ab563c7ad81215696b1ac6a3bd7b"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
+ file://navigation.conf \
+ file://navigation.token \
+"
+SRCREV = "1a014832f3da70e413650e0eeb4f40e598feb257"
S = "${WORKDIR}/git"
inherit qmake5 pkgconfig
+do_install:append() {
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/navigation
+ install -m 0644 ${WORKDIR}/navigation.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
+}
+
FILES:${PN} += "${datadir}/icons/"
RDEPENDS:${PN} += " \
diff --git a/recipes-demo/navigation/tbtnavi/tbtnavi.conf b/recipes-demo/navigation/tbtnavi/tbtnavi.conf
new file mode 100644
index 00000000..c962f305
--- /dev/null
+++ b/recipes-demo/navigation/tbtnavi/tbtnavi.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/tbtnavi/tbtnavi.token"
diff --git a/recipes-demo/navigation/tbtnavi/tbtnavi.service b/recipes-demo/navigation/tbtnavi/tbtnavi.service
new file mode 100644
index 00000000..cc040009
--- /dev/null
+++ b/recipes-demo/navigation/tbtnavi/tbtnavi.service
@@ -0,0 +1,11 @@
+[Unit]
+Requires=agl-compositor.service
+After=agl-compositor.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/tbtnavi
+Restart=on-failure
+
+[Install]
+WantedBy=agl-session.target
diff --git a/recipes-demo/navigation/tbtnavi/tbtnavi.token b/recipes-demo/navigation/tbtnavi/tbtnavi.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/navigation/tbtnavi/tbtnavi.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index d052b670..3fedf65b 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -22,12 +22,35 @@ DEPENDS = " \
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "70dfe121582cda2c82c794e5af6550b5c1a237c4"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH} \
+ file://tbtnavi.service \
+ file://tbtnavi.conf \
+ file://tbtnavi.token \
+"
+SRCREV = "27e13131ab377c4bed24f0dbd9b7e61a58a3bba8"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 systemd pkgconfig
+
+do_install:append() {
+ install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+ install -m0644 ${WORKDIR}/tbtnavi.service ${D}${systemd_user_unitdir}/tbtnavi.service
+ ln -s ../tbtnavi.service ${D}${systemd_user_unitdir}/agl-session.target.wants/tbtnavi.service
+
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/tbtnavi
+ install -m 0644 ${WORKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
+}
+
+FILES:${PN} += " ${systemd_user_unitdir}"
RDEPENDS:${PN} += " \
qtlocation \