summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-05-31 18:15:32 +0200
committerJose Dapena Paz <jdapena@igalia.com>2022-06-16 15:20:08 +0200
commitfdc1f9e02b6185c89262dfb21f9d610245068103 (patch)
tree0716daf2c943318cf35220fe8f26d237bd3e60f2
parentaebd05752a3713928bee6d1d4c4cec6ca65aafdc (diff)
html5-mixer: recover HTML5 mixer demo application.
Add updated html5-mixer: * Fixes build with new application framework providing audiomixer mock. * Updates NPM dependencies. * Updates recipe for kirkstone. Bug-AGL: SPEC-4248 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com> Change-Id: Ie0ac5edb0be83a26cf627b962472d7ac7208e1c5
-rw-r--r--recipes-demo/html5-mixer/files/webapps-mixer.desktop11
-rw-r--r--recipes-demo/html5-mixer/html5-mixer_git.bb42
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
3 files changed, 54 insertions, 0 deletions
diff --git a/recipes-demo/html5-mixer/files/webapps-mixer.desktop b/recipes-demo/html5-mixer/files/webapps-mixer.desktop
new file mode 100644
index 00000000..eab7ca36
--- /dev/null
+++ b/recipes-demo/html5-mixer/files/webapps-mixer.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Mixer
+Comment=Mixer
+GenericName=Mixer
+Exec=/usr/bin/WebAppMgr --appid=webapps-mixer --app-install-dir=/usr/lib/wam_apps/html5-mixer/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-mixer/html5-mixer_git.bb b/recipes-demo/html5-mixer/html5-mixer_git.bb
new file mode 100644
index 00000000..4a46e9bb
--- /dev/null
+++ b/recipes-demo/html5-mixer/html5-mixer_git.bb
@@ -0,0 +1,42 @@
+SUMMARY = "AGL HTML5 mixer Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mixer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
+ file://webapps-mixer.desktop \
+"
+SRCREV = "c189320ab6810d4c916fa8f697a9452f3a8976a4"
+
+inherit pythonnative
+
+DEPENDS = "nodejs-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/webapps-mixer.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${APPLICATIONS_DIR} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index b66806c4..a9fbca15 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -35,6 +35,7 @@ AGL_APPS = " \
html5-homescreen \
html5-hvac \
html5-mediaplayer \
+ html5-mixer \
ondemandnavi \
html5-settings \
"