summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-18 20:40:31 -0500
committerScott Murray <scott.murray@konsulko.com>2023-01-19 15:34:12 -0500
commit5109016c566a4a46e4a85f2c7b9dfcd6b8540233 (patch)
tree583e0da3d6df24580e86285b0d727c86c9dd36a4
parent0eb0e7ad872bc03cbc8af5c95bfe0219ebf06bfd (diff)
Make cluster dashboard KUKSA.val server configurable
Add CLUSTER_DEMO_VISS_HOSTNAME variables to the cluster-dashboard and flutter-cluster-dashboard recipes and tweak the installed configuration files to use the address it specifies. This provides a hook for tweaking the configuration for e.g. running in the guest VMs in the QEMU+KVM demo. This may need to be tweaked down the road to use something like multiple packages + the alternatives mechanism instead. Bug-AGL: SPEC-4618 Change-Id: I101b2c966fc2923a5f4946ea1c5e95695061c041 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb3
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb3
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index 254c4013..b51c581d 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -28,6 +28,8 @@ S = "${WORKDIR}/git"
inherit pkgconfig cmake_qt5
+CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+
do_install:append() {
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
install -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_user_unitdir}/${BPN}.service
@@ -39,6 +41,7 @@ do_install:append() {
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.conf ${D}${sysconfdir}/xdg/AGL/
+ sed -i "s/^server = .*/server = \"${CLUSTER_DEMO_VISS_HOSTNAME}\"/" ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.conf
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index b293795f..b0e2f81d 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -30,6 +30,8 @@ OPENROUTE_API_KEY ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
inherit flutter-app update-alternatives
+CLUSTER_DEMO_VISS_HOSTNAME ??= "192.168.10.2"
+
APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
@@ -45,6 +47,7 @@ do_install:append() {
install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml \
${D}${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.default
install -m 0644 ${WORKDIR}/flutter-cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
+ sed -i "s/^hostname: .*/hostname: ${CLUSTER_DEMO_VISS_HOSTNAME}/" ${D}${sysconfdir}/xdg/AGL/flutter-cluster-dashboard.yaml.demo
install -m 0755 -d ${D}${sysconfdir}/default/
echo 'OPENROUTE_API_KEY:${OPENROUTE_API_KEY}' >> ${D}${sysconfdir}/default/openroutekey