summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-10 13:11:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-22 10:20:55 +0000
commit7cae7f082bbf22114a3a5298733d269e4a04da8d (patch)
tree5301c2cf165d844c4f7e71ed8df84421c139f7cd
parent084773665942096e7bf2140e9f0e88346d58e54b (diff)
Switch Qt demo apps to gRPC launcher API
Changes: - Update SRCREV in libqtappfw, launcher, and homescreen recipes to pick up gRPC API changes. - Update libqtappfw recipe for switch to meson instead of CMake, and add new protobuf and gRPC dependencies. - Update launcher recipe to pull in new libqtappfw dependency, and update some formatting for consistency with the other recipes. Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib01e3b9d9bf5b422f69012bfdbd415628bbb9ab9
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb2
-rw-r--r--recipes-demo/launcher/launcher_git.bb16
-rw-r--r--recipes-demo/libqtappfw/libqtappfw_git.bb9
3 files changed, 16 insertions, 11 deletions
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index c8f5eee6..3ae2c786 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -25,7 +25,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=http
file://homescreen.conf \
file://homescreen.token \
"
-SRCREV = "e490ff1e1e31b4a837cb8063f7346dc65ffe073e"
+SRCREV = "7ffab2f5720cb4cc831612cfe678ab8f9b00a62d"
S = "${WORKDIR}/git"
diff --git a/recipes-demo/launcher/launcher_git.bb b/recipes-demo/launcher/launcher_git.bb
index 3c27fab9..52564b9c 100644
--- a/recipes-demo/launcher/launcher_git.bb
+++ b/recipes-demo/launcher/launcher_git.bb
@@ -9,7 +9,7 @@ DEPENDS = "\
qtbase \
qtdeclarative \
qtquickcontrols2 \
- qtwebsockets \
+ libqtappfw \
wayland-native \
wayland \
qtwayland \
@@ -19,15 +19,14 @@ DEPENDS = "\
applaunchd \
"
-PV = "1.0+git${SRCPV}"
+PV = "1.0+git${SRCPV}"
-SRC_URI = " \
- git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
- file://launcher.service \
- "
-SRCREV = "fd578508fe8f59a0bf11916ea99561125dcfc4ba"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH} \
+ file://launcher.service \
+"
+SRCREV = "b28d987d3fcf0c1c728d6c3cd18e52d40f6c2ffc"
-S = "${WORKDIR}/git"
+S = "${WORKDIR}/git"
inherit qmake5 systemd pkgconfig
@@ -42,6 +41,7 @@ do_install:append() {
FILES:${PN} += " ${systemd_user_unitdir}"
RDEPENDS:${PN} += " \
+ libqtappfw \
applaunchd \
homescreen \
"
diff --git a/recipes-demo/libqtappfw/libqtappfw_git.bb b/recipes-demo/libqtappfw/libqtappfw_git.bb
index 326685fe..85462264 100644
--- a/recipes-demo/libqtappfw/libqtappfw_git.bb
+++ b/recipes-demo/libqtappfw/libqtappfw_git.bb
@@ -8,22 +8,27 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
DEPENDS = " \
qtbase \
+ qtbase-native \
qtdeclarative \
qtwebsockets \
glib-2.0 \
bluez-glib \
connman-glib \
libmpdclient \
+ protobuf-native \
+ grpc-native \
+ protobuf \
+ grpc \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "a2d991a54f77017ced1558d289bcb83d73fe2a35"
+SRCREV = "187ab41bb5082d07b6a81fb9dba2564f39e9d770"
S = "${WORKDIR}/git"
# PV needs to be modified with SRCPV to work AUTOREV correctly
PV = "2.0+git${SRCPV}"
-inherit cmake_qt5 pkgconfig
+inherit meson pkgconfig
RRECOMMENDS:${PN} += "bluez5 connman mpd"