summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-05-31 17:17:32 +0200
committerJose Dapena Paz <jdapena@igalia.com>2022-06-16 15:20:08 +0200
commitaebd05752a3713928bee6d1d4c4cec6ca65aafdc (patch)
treeeaf9fe40fda39e449348ea681882bbed9aab429f
parent081030c382184dbce41e2556b2a40b021634c948 (diff)
html5-mediaplayer: recover HTML5 mediaplayer demo application.
Add updated html5-mediaplayer: * Fixes build with new application framework providing mediaplayer mock. * Updates NPM dependencies. * Updates recipe for kirkstone. Bug-AGL: SPEC-4248 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com> Change-Id: Iabc5944771a0aa7ef09b0464c6c2602f0a31c9ec
-rw-r--r--recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop11
-rw-r--r--recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb42
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb1
3 files changed, 54 insertions, 0 deletions
diff --git a/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop b/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
new file mode 100644
index 00000000..4322d6c3
--- /dev/null
+++ b/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Media Player
+Comment=Media player
+GenericName=Media player
+Exec=/usr/bin/WebAppMgr --appid=webapps-mediaplayer --app-install-dir=/usr/lib/wam_apps/html5-mediaplayer/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
new file mode 100644
index 00000000..4fd1df2d
--- /dev/null
+++ b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -0,0 +1,42 @@
+SUMMARY = "AGL HTML5 media player Application"
+HOMEPAGE = "https://git.automotivelinux.org/apps/html5-mediaplayer/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+B = "${WORKDIR}/build"
+
+SRC_URI = " \
+ git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=master \
+ file://webapps-mediaplayer.desktop \
+"
+SRCREV = "07adebd03e37a790462f80b6f3bb001bad7e6748"
+
+inherit pythonnative
+
+DEPENDS = "nodejs-native"
+
+do_compile[network] = "1"
+do_compile() {
+ cd ${S}
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
+}
+
+WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+APPLICATIONS_DIR="${datadir}/applications"
+
+do_install() {
+ install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+ install -d ${D}${APPLICATIONS_DIR}
+ install ${WORKDIR}/webapps-mediaplayer.desktop ${D}${APPLICATIONS_DIR}
+}
+
+FILES:${PN} = " \
+ ${WAM_APPLICATIONS_DIR}/${PN} \
+ ${APPLICATIONS_DIR} \
+"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
index d91c96ef..b66806c4 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
@@ -34,6 +34,7 @@ AGL_APPS = " \
html5-launcher \
html5-homescreen \
html5-hvac \
+ html5-mediaplayer \
ondemandnavi \
html5-settings \
"