summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-16 18:14:47 -0500
committerScott Murray <scott.murray@konsulko.com>2023-01-18 21:03:21 -0500
commitebeba2f0667d7195597d9131a12d880d503a399a (patch)
tree6cb49cf3f45640809c46465edf37e717051095a1
parente511c8eca18ed0d4895c8e150c8670be45fb608a (diff)
rng-tools: disable jitter entropy generation in VMs
Add a bbappend for rng-tools that disables jitter entropy generation for virtio-all machines, as it provides little value in virtual machines that are dependent on the host entropy anyways, and slows their booting very significantly. Bug-AGL: SPEC-4618 Change-Id: I51d10f95d5936a4ad89389ed5e0e4e0c16abcac6 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-support/rng-tools/files/default1
-rw-r--r--recipes-support/rng-tools/rng-tools_%.bbappend1
-rw-r--r--recipes-support/rng-tools/rng-tools_agldemo.inc7
3 files changed, 9 insertions, 0 deletions
diff --git a/recipes-support/rng-tools/files/default b/recipes-support/rng-tools/files/default
new file mode 100644
index 00000000..6e2f2ca9
--- /dev/null
+++ b/recipes-support/rng-tools/files/default
@@ -0,0 +1 @@
+EXTRA_ARGS="-r /dev/hwrng -x jitter"
diff --git a/recipes-support/rng-tools/rng-tools_%.bbappend b/recipes-support/rng-tools/rng-tools_%.bbappend
new file mode 100644
index 00000000..8ec7f750
--- /dev/null
+++ b/recipes-support/rng-tools/rng-tools_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'rng-tools_agldemo.inc', '', d)}
diff --git a/recipes-support/rng-tools/rng-tools_agldemo.inc b/recipes-support/rng-tools/rng-tools_agldemo.inc
new file mode 100644
index 00000000..283c8a4c
--- /dev/null
+++ b/recipes-support/rng-tools/rng-tools_agldemo.inc
@@ -0,0 +1,7 @@
+# Pick up modified default configuration for virtual machines
+# that disables jitter entropy source, as it is not useful when
+# the VMs are effectively driven by the host RNG via virtio-rng.
+# This also helps boot speed, as otherwise the guests have rngd
+# potentially somewhat pointlessly burning a lot of CPU on boot,
+# in addition to the host's own rngd.
+FILESEXTRAPATHS:prepend:virtio-all := "${THISDIR}/files:"