summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Dapena Paz <jdapena@igalia.com>2022-04-27 11:08:09 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-13 12:08:08 +0000
commitd38602afcce435a102ecb0aa0c40231c266d8ddf (patch)
treea8542d830a661e6c57a4c6dfc695d4fa2f43451a
parentf3e2bfbfb64222d1d80ac12f3e615ef5e392a842 (diff)
chromium=91.0.4472.114.ose11.agl, wam=ose57.agl
Move to webOS OSE 2.15.0 baseline of wam and chromium. This includes: * Migration from chromium 87.* to chromium 91.* * New error page. * Bring back LTTng support in WAM. * Misc fixes to AGL build for chromium 91. Bug-AGL: SPEC-4261 Change-Id: Ia81c515b97e27da53e054fdc89622b7be0e8e1b5 Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
-rw-r--r--recipes-wam/chromium/chromium.inc6
-rw-r--r--recipes-wam/chromium/chromium_git.bb12
-rw-r--r--recipes-wam/wam/wam_git.bb6
3 files changed, 14 insertions, 10 deletions
diff --git a/recipes-wam/chromium/chromium.inc b/recipes-wam/chromium/chromium.inc
index b641a648..d2c9e906 100644
--- a/recipes-wam/chromium/chromium.inc
+++ b/recipes-wam/chromium/chromium.inc
@@ -14,7 +14,7 @@ require gn-utils.inc
inherit gettext qemu pythonnative
-DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk at-spi2-atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native"
+DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontconfig openssl pango cairo icu libxkbcommon libexif dbus pciutils udev libcap alsa-lib virtual/egl elfutils-native libdrm atk at-spi2-atk gperf-native gconf nss nss-native nspr nspr-native bison-native qemu-native curl"
PROVIDES = "${BROWSER_APPLICATION}"
@@ -103,6 +103,9 @@ GN_ARGS += "is_debug=false is_official_build=true"
# "is_cfi requires setting is_clang = true in 'gn args'")
GN_ARGS += "is_cfi=false"
+# use_thin_lto should be also disabled for GCC
+GN_ARGS += "use_thin_lto=false"
+
# We do not want to use Chromium's own Debian-based sysroots, it is easier to
# just let Chromium's build system assume we are not using a sysroot at all and
# let Yocto handle everything.
@@ -158,6 +161,7 @@ GN_ARGS += "\
enable_nacl=false\
disable_ftp_support=true\
enable_print_preview=false\
+ enable_basic_printing=false\
enable_remoting=false\
use_glib=true\
use_gnome_keyring=false\
diff --git a/recipes-wam/chromium/chromium_git.bb b/recipes-wam/chromium/chromium_git.bb
index c710c070..6e83a5bb 100644
--- a/recipes-wam/chromium/chromium_git.bb
+++ b/recipes-wam/chromium/chromium_git.bb
@@ -1,18 +1,18 @@
require chromium.inc
SRC_URI = "\
- git://github.com/igalia/chromium87;branch=@10.agl.marlin;protocol=https;rev=${SRCREV_chromium87};name=chromium87 \
- git://github.com/webosose/chromium-v8;branch=@chromium87;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
+ git://github.com/igalia/chromium91;branch=@11.agl;protocol=https;rev=${SRCREV_chromium91};name=chromium91 \
+ git://github.com/webosose/chromium-v8;branch=@chromium91;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8;protocol=https \
"
# Needed by catapult
DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
-SRCREV_chromium87 = "c9a66f75a7f40b9fe39e168b596b9743467d7378"
-SRCREV_v8 = "935065d097cce0090bc858746e6aee0919b222de"
+SRCREV_chromium91 = "2c7cb6949542f7e16b2ffc64b4300ccc4212392b"
+SRCREV_v8 = "b958ec542dcb086f422a1216a959be38a4cc0339"
-CHROMIUM_VERSION = "87.0.4280.88"
-PV_BRANCH_SUFFIX = "ose10.agl.marlin"
+CHROMIUM_VERSION = "91.0.4472.114"
+PV_BRANCH_SUFFIX = "ose11.agl"
PV = "${CHROMIUM_VERSION}.${PV_BRANCH_SUFFIX}+git"
diff --git a/recipes-wam/wam/wam_git.bb b/recipes-wam/wam/wam_git.bb
index a59871b8..a819d6c7 100644
--- a/recipes-wam/wam/wam_git.bb
+++ b/recipes-wam/wam/wam_git.bb
@@ -25,14 +25,14 @@ lcl_maybe_fortify = ""
SECURITY_STACK_PROTECTOR = ""
SRC_URI = "\
- git://github.com/igalia/${BPN}.git;branch=@55.agl.marlin;protocol=https \
+ git://github.com/igalia/${BPN}.git;branch=@57.agl;protocol=https \
file://WebAppMgr.service \
file://WebAppMgr.env \
"
S = "${WORKDIR}/git"
-SRCREV = "f4c2e95afb0ed0cd22095d567fa437a6ccb8c5ab"
+SRCREV = "692f706b8794b093035915bc401576c55a6e03fc"
-PV = "ose55.agl.marlin"
+PV = "ose57.agl"
do_install:append() {
install -v -d ${D}${sysconfdir}/wam