summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-03-18 17:16:12 -0400
committerScott Murray <scott.murray@konsulko.com>2024-03-19 11:44:32 +0000
commit24c523366dd47a888af689ac50f31065c4cb186f (patch)
tree5960b199acbe3f5546dc64f0cf866ba584973c94
parentce73b75391878e7e144eaf9df4a4bfddca543eea (diff)
Remove meta-python dependencies
Remove remaining meta-python dependencies from layer and recipe configuration. The agl-ivi-demo-platform-html5 image has been confirmed to build with these changes, and they are a prerequisite for removing meta-python from the repo manifest. Bug-AGL: SPEC-5099 Change-Id: I1d8ff343eef2d883bbc5b5baf0f7b69b161faf94 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29745 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-demo/html5-background/html5-background_git.bb2
-rw-r--r--recipes-demo/html5-dashboard/html5-dashboard_git.bb2
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb2
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb2
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb2
-rw-r--r--recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb2
-rw-r--r--recipes-demo/html5-mixer/html5-mixer_git.bb2
-rw-r--r--recipes-demo/html5-settings/html5-settings_git.bb2
-rw-r--r--recipes-demo/webapp-samples/html5-aquarium_git.bb2
-rw-r--r--recipes-demo/webapp-samples/html5-examples_git.bb2
-rw-r--r--recipes-demo/webapp-samples/html5-jitsi_git.bb2
-rw-r--r--recipes-demo/webapp-samples/html5-youtube_git.bb2
13 files changed, 13 insertions, 13 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 501ab809..8a937a83 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -16,4 +16,4 @@ BBFILES_DYNAMIC += " \
LAYERSERIES_COMPAT_agldemo = "kirkstone"
-LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer meta-flutter meta-python2 meta-app-framework multimedia-layer"
+LAYERDEPENDS_agldemo = "aglcore qt5-layer openembedded-layer networking-layer multimedia-layer meta-flutter meta-app-framework"
diff --git a/recipes-demo/html5-background/html5-background_git.bb b/recipes-demo/html5-background/html5-background_git.bb
index 4e6bb143..c8487107 100644
--- a/recipes-demo/html5-background/html5-background_git.bb
+++ b/recipes-demo/html5-background/html5-background_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "aa7e2a81e91ed076c0bc9ba07db5aee0f34668df"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-${BPN}"
diff --git a/recipes-demo/html5-dashboard/html5-dashboard_git.bb b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
index 1a2b5c9f..586627c8 100644
--- a/recipes-demo/html5-dashboard/html5-dashboard_git.bb
+++ b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "38befd7704f64781bf4bce85fd9b2cdffc7845fa"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-dashboard"
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index 567d1d66..2c46b95a 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -14,7 +14,7 @@ PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
-inherit pythonnative systemd
+inherit systemd
DEPENDS = "nodejs-native"
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 2503e7c4..c0d4c545 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "c323ab8fde212120d8d1914d453afeb55b3576e5"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-hvac"
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index a50c175a..cc9143c2 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "ccdd59db7dc073eee0a35d0318640d9833824073"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "launcher"
diff --git a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
index 7c39f37f..c1780529 100644
--- a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
+++ b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "b87776912cc31c976415ceb49e7551f500e0975b"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-mediaplayer"
diff --git a/recipes-demo/html5-mixer/html5-mixer_git.bb b/recipes-demo/html5-mixer/html5-mixer_git.bb
index 27c3e29e..fe45ef1a 100644
--- a/recipes-demo/html5-mixer/html5-mixer_git.bb
+++ b/recipes-demo/html5-mixer/html5-mixer_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-mixer"
diff --git a/recipes-demo/html5-settings/html5-settings_git.bb b/recipes-demo/html5-settings/html5-settings_git.bb
index c8dae729..ff94276d 100644
--- a/recipes-demo/html5-settings/html5-settings_git.bb
+++ b/recipes-demo/html5-settings/html5-settings_git.bb
@@ -13,7 +13,7 @@ SRC_URI = " \
"
SRCREV = "69af4d9b9b209fcb33ef9071ddfa8561106044c2"
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-settings"
diff --git a/recipes-demo/webapp-samples/html5-aquarium_git.bb b/recipes-demo/webapp-samples/html5-aquarium_git.bb
index 7828eccb..0afc8514 100644
--- a/recipes-demo/webapp-samples/html5-aquarium_git.bb
+++ b/recipes-demo/webapp-samples/html5-aquarium_git.bb
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-aquarium.json"
require webapp-samples.inc
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-aquarium"
diff --git a/recipes-demo/webapp-samples/html5-examples_git.bb b/recipes-demo/webapp-samples/html5-examples_git.bb
index 080331ee..c2b131af 100644
--- a/recipes-demo/webapp-samples/html5-examples_git.bb
+++ b/recipes-demo/webapp-samples/html5-examples_git.bb
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-examples.json"
require webapp-samples.inc
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-examples"
diff --git a/recipes-demo/webapp-samples/html5-jitsi_git.bb b/recipes-demo/webapp-samples/html5-jitsi_git.bb
index e24ff32a..e382cb03 100644
--- a/recipes-demo/webapp-samples/html5-jitsi_git.bb
+++ b/recipes-demo/webapp-samples/html5-jitsi_git.bb
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-jitsi.json"
require webapp-samples.inc
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-jitsi"
diff --git a/recipes-demo/webapp-samples/html5-youtube_git.bb b/recipes-demo/webapp-samples/html5-youtube_git.bb
index 240ce858..44a96440 100644
--- a/recipes-demo/webapp-samples/html5-youtube_git.bb
+++ b/recipes-demo/webapp-samples/html5-youtube_git.bb
@@ -5,7 +5,7 @@ APPINFO_FILE = "appinfo-youtube.json"
require webapp-samples.inc
-inherit pythonnative agl-app
+inherit agl-app
AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-youtube"