summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2024-02-03 14:19:32 -0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-07 13:56:20 +0000
commit2c6bebcaee2e8626a38ca673ebb3b85fd9163411 (patch)
treee30ca942fb247aeca9ca2c2b71086360cd6189d2
parentf113093be3d4a32cd44e48c88d60a9e84fdd6b0a (diff)
webapps: Bump html5-hvac SRCREV
Includes changes needed to make the application start using gRPC-WEB Bug-AGL: SPEC-4599 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: I96cd5f5a9b56180eb44c157c0af705a67d406b92 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29657 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 61b6d48c..2503e7c4 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -11,7 +11,7 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
"
-SRCREV = "5f1b6075982b872b5db4e2195e53d19529278d5c"
+SRCREV = "c323ab8fde212120d8d1914d453afeb55b3576e5"
inherit pythonnative agl-app
@@ -19,13 +19,14 @@ AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-hvac"
AGL_APP_NAME = "HTML5 HVAC"
-DEPENDS = "nodejs-native"
+DEPENDS = "nodejs-native protobuf-native"
do_compile[network] = "1"
do_compile() {
cd ${S}
rm -rf package node_modules package-lock.json
npm install
+ npm run generate-grpc
npm run build
}