summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-20 15:52:31 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-03-08 18:27:03 +0000
commit3a72cfd21cdd03401ea3208afd721d83c220d3e8 (patch)
tree150e3a50b3faae681df2940695f615e7ab6dea71
parent188db67d4205a7d37c374cc20d9d3bd90324cb41 (diff)
agl-ivi-demo-platform-flutter: add ondemandnavi
Add ondemandnavi application to new default Flutter demo image, and update both it and tbtnavi's runtime dependencies to make sure all the required Qt packages get pulled into the image. Bug-AGL: SPEC-5085 Change-Id: I521a7e3a1d161f2283023f8fa346092f961ac4ba Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29701 ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb7
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb3
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform-flutter.bb1
3 files changed, 11 insertions, 0 deletions
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index 3baac2a0..5fa27aa5 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -37,6 +37,13 @@ do_install:append() {
}
RDEPENDS:${PN} += " \
+ qtwayland \
+ qtbase-qmlplugins \
+ qtgraphicaleffects-qmlplugins \
+ qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
+ qtquickcontrols2-agl \
+ qtquickcontrols2-agl-style \
qtlocation \
flite \
libqtappfw \
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index 1720e898..b6213813 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -53,6 +53,9 @@ do_install:append() {
}
RDEPENDS:${PN} += " \
+ qtwayland \
+ qtbase-qmlplugins \
+ qtgraphicaleffects-qmlplugins \
qtlocation \
ondemandnavi-config \
libqtappfw \
diff --git a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
index 82e32887..a50c00bf 100644
--- a/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform-flutter.bb
@@ -4,4 +4,5 @@ DESCRIPTION = "AGL Flutter Demo Platform image"
AGL_APPS_INSTALL += " \
flutter-ics-homescreen \
+ ondemandnavi \
"