summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-01-30 16:36:41 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-02 12:16:48 +0000
commit4d8f8b5303e776bd304d5a086049c0c4f80f8942 (patch)
treeb1191032bf58bcaa3b523da81cf645a4c50a6350
parented344ae0d62b25f73c8816a2c8fb6e8168424425 (diff)
flutter-ics-homescreen: update SRCREV
Update SRCREV to pick up: 5587c6a Improve background disabling 6046300 Fix TLS server name parsing cc99d4d Connect audio settings button ee592b5 Rotate dashboard gauges 31438c5 Configurable units fixes 5588d1d Tweak idle speed in hybrid animation logic 2d395f4 Initial mediaplayer implementation 4742fde Initial radio implementation fcd868b Fix late initialization warning a445ffb Add application launcher support 4ae68f5 Implement audio settings dda6c85 Hybrid animation from env variable As well, the configuration yaml file has been updated to work with the changes, and a radio presets configuration yaml file has been added. Bug-AGL: SPEC-4971, SPEC-5001, SPEC-5026, SPEC-5027, SPEC-5028, SPEC-5029, SPEC-5030, SPEC-5031, SPEC-5032, SPEC-5043, SPEC-5053, SPEC-5054 Change-Id: I0820ab2c7eaba8cbdc8df6fb05e6244df70622d2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29640 Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml7
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml13
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb35
3 files changed, 39 insertions, 16 deletions
diff --git a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
index eb29ea73..f8e400b3 100644
--- a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
+++ b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
@@ -1,3 +1,4 @@
-port : 55555
-authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
-use-tls : true
+kuksa:
+ port : 55555
+ authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
+ use-tls : true
diff --git a/recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml b/recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml
new file mode 100644
index 00000000..6af08377
--- /dev/null
+++ b/recipes-demo/flutter-ics-homescreen/files/radio-presets.yaml
@@ -0,0 +1,13 @@
+fm:
+- frequency: 93100000
+ name: 93.1 The Mountain
+- frequency: 94100000
+ name: Mix 94.1
+- frequency: 96300000
+ name: 96.3 KKLZ
+- frequency: 102700000
+ name: 102.7 VGS
+- frequency: 88900000
+ name: News 88.9
+- frequency: 91500000
+ name: KUNV
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 77ed5090..dd50df72 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -11,8 +11,9 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
file://flutter-ics-homescreen.service \
file://ics-homescreen.yaml \
file://ics-homescreen.token \
+ file://radio-presets.yaml \
"
-SRCREV = "71d46d03850653c0229c678de197c6f94fceb477"
+SRCREV = "5587c6ae79b482fbff26442bb239d7d7eb55a337"
S = "${WORKDIR}/git"
@@ -33,18 +34,26 @@ DISABLE_BG_ANIMATION:rcar-gen3 = ""
APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
-
- install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
-
- # VIS authorization token file for KUKSA.val should ideally not
- # be readable by other users, but currently that's not doable
- # until a packaging/sandboxing/MAC scheme is (re)implemented or
- # something like OAuth is plumbed in as an alternative.
- install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
- install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
+ install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+
+ install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/${BPN}.json
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
+ install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
+ install -m 0644 ${WORKDIR}/radio-presets.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
}
FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
-RDEPENDS:${PN} += "flutter-auto agl-flutter-env"
+
+RDEPENDS:${PN} += " \
+ flutter-auto \
+ agl-flutter-env \
+ applaunchd \
+ agl-service-radio \
+ mpd \
+"