summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2024-02-05 15:20:03 -0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-07 16:15:38 +0000
commit5fcefd9f7ea45383af5515df1abd75d6edbc50d4 (patch)
tree7c2a45547f04a650b4d653f5841c2c8fc5aec28a
parentc7e83fdf048b49187b182a811c3a7d76bedba24f (diff)
cef: use vpython3 for commands called by gclientquillback_16.93.0quillback/16.93.016.93.0
The probable cause for SPEC-5062 is that chromium's go routines that create virtualenvs expect vpython environment variables to be present, so the creation fails and the scripts could be trying to use the build host python binary. This can cause issues on some places, for example in the codecs lookup that raises an exception when an codec isn't found: https://github.com/pypa/pip/pull/6311/files The exception raised on SPEC-5062 logs is "unknown encoding: utf-16le", because the sysroot pip version expects "utf-16-le" instead. Bug-AGL: SPEC-5062 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: I16e817140bf819712a5fbe1b006156db608d43b2 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29659 ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--recipes-wam/cef/cef_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-wam/cef/cef_git.bb b/recipes-wam/cef/cef_git.bb
index 8227dd13..4a87631b 100644
--- a/recipes-wam/cef/cef_git.bb
+++ b/recipes-wam/cef/cef_git.bb
@@ -307,9 +307,9 @@ do_configure () {
# Download a few dependencies. Check the current chromium DEPS file when
# upgrading to a new milestone.
- python3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-fonts -s third_party/test_fonts/test_fonts.tar.gz.sha1
- python3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-nodejs/16.13.0 -s third_party/node/linux/node-linux-x64.tar.gz.sha1
- python3 tools/rust/update_rust.py
+ vpython3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-fonts -s third_party/test_fonts/test_fonts.tar.gz.sha1
+ vpython3 third_party/depot_tools/download_from_google_storage.py --no_resume --extract --no_auth --bucket chromium-nodejs/16.13.0 -s third_party/node/linux/node-linux-x64.tar.gz.sha1
+ vpython3 tools/rust/update_rust.py
cd ${S}/cef
python3 tools/gclient_hook.py --base-out-path ${B} --bypass-sysroot-check