summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2024-02-03 15:27:55 -0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-02-07 16:15:38 +0000
commitc7e83fdf048b49187b182a811c3a7d76bedba24f (patch)
treef4a7c479032efb67e2d305d50b0c5398f13200cc
parent2c6bebcaee2e8626a38ca673ebb3b85fd9163411 (diff)
webapps: Bump html5-mixer SRCREV
Includes changes needed to make the application start using gRPC-WEB Bug-AGL: SPEC-4599 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: Ib9506453085ee36f446bcda3726595a47bb4593c Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29658 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/html5-mixer/html5-mixer_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-demo/html5-mixer/html5-mixer_git.bb b/recipes-demo/html5-mixer/html5-mixer_git.bb
index 195478fd..27c3e29e 100644
--- a/recipes-demo/html5-mixer/html5-mixer_git.bb
+++ b/recipes-demo/html5-mixer/html5-mixer_git.bb
@@ -11,7 +11,7 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
"
-SRCREV = "38587cf96c096a204cd742fff9fea4f8e465393a"
+SRCREV = "e57fc753b3a083ddea52dbe4cd003261e836b2d4"
inherit pythonnative agl-app
@@ -19,13 +19,14 @@ AGL_APP_TEMPLATE = "agl-app-web"
AGL_APP_ID = "webapps-mixer"
AGL_APP_NAME = "HTML5 Mixer"
-DEPENDS = "nodejs-native"
+DEPENDS = "nodejs-native protobuf-native"
do_compile[network] = "1"
do_compile() {
cd ${S}
rm -rf package node_modules package-lock.json
npm install
+ npm run generate-grpc
npm run build
}