summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-01 16:28:35 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-29 14:29:37 +0000
commitc76683f4f8ecb50675d5fbc7f6745a4a8122b9b9 (patch)
treeeec35c0c04c6a76d80c75e0e7cac16e36ae5eb10
parentd1d39f2d808b42c10b42faa016f99ac363dc5226 (diff)
flutter-homescreen: Update SRCREV
Update SRCREV to pick up: 5ce59ba UI Fixes 3caff56 Improve app listing 4fbd3fd Add volume control to bottom panel As well, add installation of a now required configuration .yaml file to enable the KUKSA.val usage added by 8528b5b. Bug-AGL: SPEC-4615, SPEC-4659 Change-Id: I38ac698472acd169e9f6c8e4becf28a98e37ad42 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-demo/flutter-homescreen/files/homescreen_config.yaml3
-rw-r--r--recipes-demo/flutter-homescreen/flutter-homescreen_git.bb8
2 files changed, 9 insertions, 2 deletions
diff --git a/recipes-demo/flutter-homescreen/files/homescreen_config.yaml b/recipes-demo/flutter-homescreen/files/homescreen_config.yaml
new file mode 100644
index 00000000..6824c6b7
--- /dev/null
+++ b/recipes-demo/flutter-homescreen/files/homescreen_config.yaml
@@ -0,0 +1,3 @@
+hostname : localhost
+port : 8090
+kuskaAuthToken : eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJtb2RpZnlUcmVlIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.p2cnFGH16QoQ14l6ljPVKggFXZKmD-vrw8G6Vs6DvAokjsUG8FHh-F53cMsE-GDjyZH_1_CrlDCnbGlqjsFbgAylqA7IAJWp9_N6dL5p8DHZTwlZ4IV8L1CtCALs7XVqvcQKHCCzB63Y8PgVDCAqpQSRb79JPVD4pZwkBKpOknfEY5y9wfbswZiRKdgz7o61_oFnd-yywpse-23HD6v0htThVF1SuGL1PuvGJ8p334nt9bpkZO3gaTh1xVD_uJMwHzbuBCF33_f-I5QMZO6bVooXqGfe1zvl3nDrPEjq1aPulvtP8RgREYEqE6b2hB8jouTiC_WpE3qrdMw9sfWGFbm04qC-2Zjoa1yYSXoxmYd0SnliSYHAad9aXoEmFENezQV-of7sc-NX1-2nAXRAEhaqh0IRuJwB4_sG7SvQmnanwkz-sBYxKqkoFpOsZ6hblgPDOPYY2NAsZlYkjvAL2mpiInrsmY_GzGsfwPeAx31iozImX75rao8rm-XucAmCIkRlpBz6MYKCjQgyRz3UtZCJ2DYF4lKqTjphEAgclbYZ7KiCuTn9HualwtEmVzHHFneHMKl7KnRQk-9wjgiyQ5nlsVpCCblg6JKr9of4utuPO3cBvbjhB4_ueQ40cpWVOICcOLS7_w0i3pCq1ZKDEMrYDJfz87r2sU9kw1zeFQk
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
index 1f6f0188..e97bded1 100644
--- a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
+++ b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
@@ -11,8 +11,9 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-homescreen;proto
file://flutter-homescreen-profile.json \
file://flutter-homescreen-release.json \
file://flutter-homescreen.service \
+ file://homescreen_config.yaml \
"
-SRCREV = "e21709c9601209e26d09dea0a45e37f0636bb605"
+SRCREV = "5ce59ba69f1451ec18c565b7b18301856553f574"
S = "${WORKDIR}/git"
@@ -33,6 +34,9 @@ do_install:append() {
ln -s ../flutter-homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-homescreen.service
install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/flutter-homescreen.json
+
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/homescreen_config.yaml ${D}${sysconfdir}/xdg/AGL/
}
-FILES:${PN} += "${datadir} ${systemd_user_unitdir}"
+FILES:${PN} += "${datadir} ${systemd_user_unitdir} ${sysconfdir}/xdg/AGL"