summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 17:02:54 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:39:16 -0400
commit731adc93b2fed74bc4410dff510fb019d10f253f (patch)
tree77f17ab8b7b906a288d84f99f2cb4cde6fa537ff
parentf22d415e4b1290cbba736df7d4cafa043dc8f8f2 (diff)
Updates for application enumeration via systemd units
Update application recipes to use the new agl-app.bbclass to install the now required by applaunchd systemd template unit instances. The previously used .desktop files have been removed, and it is believed that the required configuration with respect to application display names has been captured in the new agl-app configuration variables. Bug-AGL: SPEC-4466 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2925a68f911646c287bc7128bb0e5f43d55ce7bf
-rw-r--r--recipes-demo/dashboard/dashboard_git.bb12
-rw-r--r--recipes-demo/html5-background/files/webapps-html5-background.desktop11
-rw-r--r--recipes-demo/html5-background/html5-background_git.bb17
-rw-r--r--recipes-demo/html5-dashboard/files/webapps-dashboard.desktop11
-rw-r--r--recipes-demo/html5-dashboard/html5-dashboard_git.bb17
-rw-r--r--recipes-demo/html5-homescreen/html5-homescreen_git.bb4
-rw-r--r--recipes-demo/html5-hvac/files/webapps-hvac.desktop11
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb17
-rw-r--r--recipes-demo/html5-launcher/files/launcher.desktop11
-rw-r--r--recipes-demo/html5-launcher/html5-launcher_git.bb17
-rw-r--r--recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop11
-rw-r--r--recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb17
-rw-r--r--recipes-demo/html5-mixer/files/webapps-mixer.desktop11
-rw-r--r--recipes-demo/html5-mixer/html5-mixer_git.bb17
-rw-r--r--recipes-demo/html5-settings/files/webapps-settings.desktop11
-rw-r--r--recipes-demo/html5-settings/html5-settings_git.bb17
-rw-r--r--recipes-demo/hvac/hvac_git.bb12
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb12
-rw-r--r--recipes-demo/messaging/messaging_git.bb10
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb13
-rw-r--r--recipes-demo/phone/phone_git.bb10
-rw-r--r--recipes-demo/radio/radio_git.bb10
-rw-r--r--recipes-demo/settings/settings_git.bb10
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb26
24 files changed, 81 insertions, 234 deletions
diff --git a/recipes-demo/dashboard/dashboard_git.bb b/recipes-demo/dashboard/dashboard_git.bb
index 70b5ad4b7..64eb2f017 100644
--- a/recipes-demo/dashboard/dashboard_git.bb
+++ b/recipes-demo/dashboard/dashboard_git.bb
@@ -22,7 +22,9 @@ SRCREV = "4efe67714e60e2ab86acf1edee500373f6820954"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "Dashboard"
do_install:append() {
# Currently using default global client and CA certificates
@@ -37,14 +39,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/dashboard.token ${D}${sysconfdir}/xdg/AGL/dashboard/
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/dashboard.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/dashboard.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
-
RDEPENDS:${PN} += " \
qtwayland \
qtbase-qmlplugins \
diff --git a/recipes-demo/html5-background/files/webapps-html5-background.desktop b/recipes-demo/html5-background/files/webapps-html5-background.desktop
deleted file mode 100644
index be474705d..000000000
--- a/recipes-demo/html5-background/files/webapps-html5-background.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Background
-Comment=Background
-GenericName=Background
-Exec=/usr/bin/WebAppMgr --appid=webapps-html5-background --app-install-dir=/usr/lib/wam_apps/html5-background/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-background/html5-background_git.bb b/recipes-demo/html5-background/html5-background_git.bb
index 1488f2468..656923a77 100644
--- a/recipes-demo/html5-background/html5-background_git.bb
+++ b/recipes-demo/html5-background/html5-background_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
- file://webapps-html5-background.desktop \
"
SRCREV = "e91be225127ddea6be3ddae5cb35e88c2f0aafb8"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-${BPN}"
+AGL_APP_NAME = "HTML5 Background"
DEPENDS = "nodejs-native"
@@ -26,19 +29,13 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-html5-background.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
RCONFLICTS:${PN} = "homescreen"
diff --git a/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop b/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop
deleted file mode 100644
index 49da96496..000000000
--- a/recipes-demo/html5-dashboard/files/webapps-dashboard.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Dashboard
-Comment=Dashboard
-GenericName=Dashboard
-Exec=/usr/bin/WebAppMgr --appid=webapps-dashboard --app-install-dir=/usr/lib/wam_apps/html5-dashboard/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-dashboard/html5-dashboard_git.bb b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
index b5118072d..8509746f2 100644
--- a/recipes-demo/html5-dashboard/html5-dashboard_git.bb
+++ b/recipes-demo/html5-dashboard/html5-dashboard_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=master \
- file://webapps-dashboard.desktop \
"
SRCREV = "4680db99615757df9d9cc561c9a9fc5b9b1c108a"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-dashboard"
+AGL_APP_NAME = "HTML5 Dashboard"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-dashboard.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/recipes-demo/html5-homescreen/html5-homescreen_git.bb b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
index db659760a..65de72985 100644
--- a/recipes-demo/html5-homescreen/html5-homescreen_git.bb
+++ b/recipes-demo/html5-homescreen/html5-homescreen_git.bb
@@ -26,13 +26,13 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
+ install -m 0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
}
diff --git a/recipes-demo/html5-hvac/files/webapps-hvac.desktop b/recipes-demo/html5-hvac/files/webapps-hvac.desktop
deleted file mode 100644
index 3e7f0dc8e..000000000
--- a/recipes-demo/html5-hvac/files/webapps-hvac.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 HVAC
-Comment=HVAC
-GenericName=HVAC
-Exec=/usr/bin/WebAppMgr --appid=webapps-hvac --app-install-dir=/usr/lib/wam_apps/html5-hvac/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 7a1ecce53..dda72782b 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
- file://webapps-hvac.desktop \
"
SRCREV = "6abbe876aee09b225af9329e28b4fa2cc4d4c220"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-hvac"
+AGL_APP_NAME = "HTML5 HVAC"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-hvac.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/recipes-demo/html5-launcher/files/launcher.desktop b/recipes-demo/html5-launcher/files/launcher.desktop
deleted file mode 100644
index b3e8e4390..000000000
--- a/recipes-demo/html5-launcher/files/launcher.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Launcher
-Comment=Launcher
-GenericName=Launcher
-Exec=/usr/bin/WebAppMgr --appid=launcher --app-install-dir=/usr/lib/wam_apps/html5-launcher/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-launcher/html5-launcher_git.bb b/recipes-demo/html5-launcher/html5-launcher_git.bb
index 83e7f8070..3595423b9 100644
--- a/recipes-demo/html5-launcher/html5-launcher_git.bb
+++ b/recipes-demo/html5-launcher/html5-launcher_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
- file://launcher.desktop \
"
SRCREV = "1283e3bddd4655be0d5208fbbcd9535f8f1ff0f6"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "launcher"
+AGL_APP_NAME = "HTML5 Launcher"
DEPENDS = "nodejs-native"
@@ -26,20 +29,14 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/launcher.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
RCONFLICTS:${PN} = "launcher"
RDEPENDS:${PN} = "applaunchd"
diff --git a/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop b/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
deleted file mode 100644
index 4322d6c34..000000000
--- a/recipes-demo/html5-mediaplayer/files/webapps-mediaplayer.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Media Player
-Comment=Media player
-GenericName=Media player
-Exec=/usr/bin/WebAppMgr --appid=webapps-mediaplayer --app-install-dir=/usr/lib/wam_apps/html5-mediaplayer/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
index 4fd1df2de..53efa8fd3 100644
--- a/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
+++ b/recipes-demo/html5-mediaplayer/html5-mediaplayer_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=master \
- file://webapps-mediaplayer.desktop \
"
SRCREV = "07adebd03e37a790462f80b6f3bb001bad7e6748"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-mediaplayer"
+AGL_APP_NAME = "HTML5 Media Player"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-mediaplayer.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/recipes-demo/html5-mixer/files/webapps-mixer.desktop b/recipes-demo/html5-mixer/files/webapps-mixer.desktop
deleted file mode 100644
index eab7ca36f..000000000
--- a/recipes-demo/html5-mixer/files/webapps-mixer.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Mixer
-Comment=Mixer
-GenericName=Mixer
-Exec=/usr/bin/WebAppMgr --appid=webapps-mixer --app-install-dir=/usr/lib/wam_apps/html5-mixer/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-mixer/html5-mixer_git.bb b/recipes-demo/html5-mixer/html5-mixer_git.bb
index 4a46e9bbf..b6b581415 100644
--- a/recipes-demo/html5-mixer/html5-mixer_git.bb
+++ b/recipes-demo/html5-mixer/html5-mixer_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=master \
- file://webapps-mixer.desktop \
"
SRCREV = "c189320ab6810d4c916fa8f697a9452f3a8976a4"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-mixer"
+AGL_APP_NAME = "HTML5 Mixer"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-mixer.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/recipes-demo/html5-settings/files/webapps-settings.desktop b/recipes-demo/html5-settings/files/webapps-settings.desktop
deleted file mode 100644
index d1081bf4b..000000000
--- a/recipes-demo/html5-settings/files/webapps-settings.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=HTML5 Settings
-Comment=Settings
-GenericName=Settings
-Exec=/usr/bin/WebAppMgr --appid=webapps-settings --app-install-dir=/usr/lib/wam_apps/html5-settings/
-Icon=settings
-Terminal=false
-Type=Application
-Categories=System;
-StartupNotify=true
diff --git a/recipes-demo/html5-settings/html5-settings_git.bb b/recipes-demo/html5-settings/html5-settings_git.bb
index edbd80f2c..c8dae7291 100644
--- a/recipes-demo/html5-settings/html5-settings_git.bb
+++ b/recipes-demo/html5-settings/html5-settings_git.bb
@@ -10,11 +10,14 @@ B = "${WORKDIR}/build"
SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=master \
- file://webapps-settings.desktop \
"
SRCREV = "69af4d9b9b209fcb33ef9071ddfa8561106044c2"
-inherit pythonnative
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-settings"
+AGL_APP_NAME = "HTML5 Settings"
DEPENDS = "nodejs-native"
@@ -26,17 +29,11 @@ do_compile() {
npm run build
}
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-APPLICATIONS_DIR="${datadir}/applications"
+WAM_APPLICATIONS_DIR = "${libdir}/wam_apps"
do_install() {
install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
cp -R --no-dereference --preserve=mode,links ${S}/dist/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install -d ${D}${APPLICATIONS_DIR}
- install ${WORKDIR}/webapps-settings.desktop ${D}${APPLICATIONS_DIR}
}
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
- ${APPLICATIONS_DIR} \
-"
+FILES:${PN} = "${WAM_APPLICATIONS_DIR}/${PN}"
diff --git a/recipes-demo/hvac/hvac_git.bb b/recipes-demo/hvac/hvac_git.bb
index 99a22e364..2ac6a69b1 100644
--- a/recipes-demo/hvac/hvac_git.bb
+++ b/recipes-demo/hvac/hvac_git.bb
@@ -24,7 +24,9 @@ SRCREV = "d37674bb6dbb5ceb15c650a0344b0caf624963bc"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "HVAC"
do_install:append() {
# Currently using default global client and CA certificates
@@ -39,14 +41,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/hvac.token ${D}${sysconfdir}/xdg/AGL/hvac/
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/hvac.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/hvac.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
-
RDEPENDS:${PN} += " \
qtwayland \
qtbase-qmlplugins \
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 9458212ad..ff84ae8a2 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -18,7 +18,9 @@ SRCREV = "9c7c1d105faeb57a5b79578318c5731d252c5414"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "Mediaplayer"
do_install:append() {
# Currently using default global client and CA certificates
@@ -33,12 +35,4 @@ do_install:append() {
install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/mediaplayer.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/mediaplayer.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
-
RDEPENDS:${PN} += "libqtappfw mpd"
diff --git a/recipes-demo/messaging/messaging_git.bb b/recipes-demo/messaging/messaging_git.bb
index c7ce8cb39..972e9b828 100644
--- a/recipes-demo/messaging/messaging_git.bb
+++ b/recipes-demo/messaging/messaging_git.bb
@@ -15,14 +15,8 @@ SRCREV = "e58b0382de8e665d64b8e3486022a6bcb0572823"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/messaging.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/messaging.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
+AGL_APP_NAME = "Messaging"
RDEPENDS:${PN} += "libqtappfw"
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index d1069c315..922a70fd8 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -18,7 +18,10 @@ SRCREV = "1a014832f3da70e413650e0eeb4f40e598feb257"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_ID = "navigation"
+AGL_APP_NAME = "Navigation"
do_install:append() {
# Currently using default global client and CA certificates
@@ -33,14 +36,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/navigation.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/navigation.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
-
RDEPENDS:${PN} += " \
qtlocation \
flite \
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
index e8b8d9ab6..4c59bcbc3 100644
--- a/recipes-demo/phone/phone_git.bb
+++ b/recipes-demo/phone/phone_git.bb
@@ -15,14 +15,10 @@ SRCREV = "bfcc2fa194474a7bc317583072b62c977ae0fc14"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/phone.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/phone.desktop
-}
+AGL_APP_NAME = "Phone"
-FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
+FILES:${PN} += "${datadir}/sounds/"
RDEPENDS:${PN} += "libqtappfw"
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index fcbbd634c..22b220100 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -19,7 +19,7 @@ SRCREV = "f48bb2aab34273bd5b3cc1f9f9d88afbfb231d6b"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
# ALS, CES, FOSDEM available
AGL_RADIO_PRESETS_LOCALE ?= "CES"
@@ -31,12 +31,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/radio.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/radio.desktop
-}
-
-FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
+FILES:${PN} += "${sysconfdir}/xdg/AGL/*"
RDEPENDS:${PN} += "libqtappfw"
diff --git a/recipes-demo/settings/settings_git.bb b/recipes-demo/settings/settings_git.bb
index 0f31860ad..c090ec7f8 100644
--- a/recipes-demo/settings/settings_git.bb
+++ b/recipes-demo/settings/settings_git.bb
@@ -21,15 +21,9 @@ SRCREV = "26dc6a8c8847248450bf902124b7cd867e027274"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/settings.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/settings.desktop
-}
-
-FILES:${PN} += "${datadir}/icons/"
+AGL_APP_NAME = "Settings"
RDEPENDS:${PN} += " \
qtwayland \
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
index 573e2df02..a34c41485 100644
--- a/recipes-graphics/wayland/weston-terminal-conf.bb
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -2,30 +2,20 @@ SUMMARY = "AGL user session"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-SRC_URI = " \
- file://org.freedesktop.weston.wayland-terminal.desktop \
- file://weston-terminal.desktop \
-"
+inherit allarch agl-app
-inherit allarch
+AGL_APP_ID = "org.freedesktop.weston.wayland-terminal"
+AGL_APP_EXEC = "weston-terminal"
+AGL_APP_NAME = "Weston Terminal"
do_install() {
- install -d ${D}${datadir}/applications
- install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
-
# Enable systemd sandboxing override as a demonstration
- mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
- ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
-
- # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
- install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
+ install -d ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
+ ln -sf ${systemd_system_unitdir}/sandboxing/no-network.conf ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
}
FILES:${PN} = " \
- ${datadir}/applications \
- ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
+ ${sysconfdir}/systemd/system/agl-app@${AGL_APP_ID}.service.d \
"
-RDEPENDS:${PN} = " \
- weston \
-"
+RDEPENDS:${PN} = "weston"