summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-24 00:20:45 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-28 12:27:48 +0000
commit9b20b1c48912b225e246a63ac84c2b6c6355654a (patch)
tree51e31bb900caa9af708aba6a17d00f6ba5145269
parentc75d04a5ee7c32e0405ecb6de0c20d7f48b7f1e9 (diff)
Explicitly add CA certificate package to cluster images
Explicitly add kuksa-certificates-ca-agl to the cluster demo images so it will be included in both regular and agl-demo-preload builds. Also remove obsolete dependency on kuksa-val-certificates-client from the cluster-dashboard recipe. These changes fix the regular vs agl-demo-preload behavior for the agl-cluster-demo-platform build. Bug-AGL: SPEC-4986 Change-Id: I62b1d976c66824fde50a3effdcdd34b428e82d54 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29472 ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account (cherry picked from commit b5ca98fe204a7ec6f4a1cf84c19ffeb5f4deb128) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29365 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--recipes-demo/cluster-dashboard/cluster-dashboard_git.bb1
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform-flutter.bb1
-rw-r--r--recipes-platform/images/agl-cluster-demo-platform.bb1
3 files changed, 2 insertions, 1 deletions
diff --git a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
index 1404f671..fc0b35cd 100644
--- a/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
+++ b/recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
@@ -54,5 +54,4 @@ RDEPENDS:${PN} += " \
qtquickcontrols2-qmlplugins \
qtgraphicaleffects-qmlplugins \
qtsvg-plugins \
- kuksa-val-certificates-client \
"
diff --git a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
index a6514c75..114e770e 100644
--- a/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform-flutter.bb
@@ -29,6 +29,7 @@ IMAGE_INSTALL += "\
packagegroup-agl-networking \
cluster-receiver \
\
+ kuksa-certificates-agl-ca \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${IMAGE_KUKSA_PACKAGES}", d)} \
simple-can-simulator \
"
diff --git a/recipes-platform/images/agl-cluster-demo-platform.bb b/recipes-platform/images/agl-cluster-demo-platform.bb
index f0b04a6b..e7074c87 100644
--- a/recipes-platform/images/agl-cluster-demo-platform.bb
+++ b/recipes-platform/images/agl-cluster-demo-platform.bb
@@ -13,6 +13,7 @@ REQUIRED_DISTRO_FEATURES = "wayland"
# add packages for cluster demo platform (include demo apps) here
IMAGE_INSTALL += " \
packagegroup-agl-cluster-demo-platform \
+ kuksa-certificates-agl-ca \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \