summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-12-07 19:00:11 +0900
committerScott Murray <scott.murray@konsulko.com>2022-12-10 07:48:31 +0000
commit1460f80a5f49785b3b713bf8a8787d64630cb3c8 (patch)
tree988f2cdbd391ed0390d0ef97499840ec08995f1c
parent8b6cd106f1090bc3ee0640502d36bc493b8ccf70 (diff)
Remove demo sllin configuration
Remove recipes providing sllin configuration for the full demo, as all LIN usage is being replaced with CAN. The recipes for the sllin driver and associated lin_config utility are kept for now in case there are external uses. Bug-AGL: SPEC-4635 Change-Id: I67b7acf5a8c3801cb1890ee27486080255252385 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb34
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/config-sllin.ini21
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/kuksa-dbc-feeder-sllin.service12
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb31
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/agl-service-hvac-can.conf.demo2
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/sllin.conf3
-rw-r--r--recipes-kernel/sllin/files/lin_config.conf10
-rw-r--r--recipes-kernel/sllin/files/sllin-demo.service12
-rwxr-xr-xrecipes-kernel/sllin/files/start_lin_demo.sh59
-rw-r--r--recipes-kernel/sllin/sllin-demo.bb29
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb14
11 files changed, 0 insertions, 227 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb
deleted file mode 100644
index 0a86cbbb..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-SUMMARY = "Demo LIN configuration for DBC feeder for KUKSA.val"
-HOMEPAGE = "https://github.com/eclipse/kuksa.val"
-BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI += "file://config-sllin.ini \
- file://kuksa-dbc-feeder-sllin.service \
-"
-
-inherit allarch systemd
-
-SYSTEMD_SERVICE:${PN} = "${BPN}.service"
-
-do_install() {
- # NOTE: Installing into same /etc directory as the main configuration for now,
- # this may be worth re-evaluating at some point (e.g. splitting the DBC
- # files, having a dedicated token, etc.).
- install -d ${D}${sysconfdir}/kuksa-dbc-feeder
- install -m 0644 ${WORKDIR}/config-sllin.ini ${D}${sysconfdir}/kuksa-dbc-feeder/
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/kuksa-dbc-feeder-sllin.service ${D}${systemd_system_unitdir}
- fi
-}
-
-FILES:${PN} += "${systemd_system_unitdir}"
-
-RDEPENDS:${PN} += " \
- kuksa-dbc-feeder \
- can-dev-helper \
- sllin-demo \
-"
diff --git a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/config-sllin.ini b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/config-sllin.ini
deleted file mode 100644
index 24d63795..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/config-sllin.ini
+++ /dev/null
@@ -1,21 +0,0 @@
-[general]
-# use case:
-# switch between databroker and kuksa
-# default kuksa
-usecase = kuksa
-# VSS mapping file
-mapping=/etc/kuksa-dbc-feeder/mapping.yml
-
-[kuksa_val]
-# kuksa VSS server address
-server=wss://localhost:8090
-# JWT security token file
-token=/etc/kuksa-dbc-feeder/dbc_feeder.json.token
-
-[can]
-# CAN port
-port=sllin0
-#Enable SAE-J1939 Mode. False: ignore
-j1939=False
-# DBC file used to parse CAN messages
-dbcfile=/etc/kuksa-dbc-feeder/agl-vcar.dbc
diff --git a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/kuksa-dbc-feeder-sllin.service b/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/kuksa-dbc-feeder-sllin.service
deleted file mode 100644
index 8f830de7..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-dbc-feeder-sllin/kuksa-dbc-feeder-sllin.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Eclipse KUKSA.val DBC feeder (sllin0)
-Requires=kuksa-val.service sllin-demo.service
-After=kuksa-val.service sllin-demo.service
-
-[Service]
-ExecStartPre=/usr/sbin/can-dev-helper.sh /etc/kuksa-dbc-feeder/config-sllin.ini
-ExecStart=/usr/bin/dbcfeeder.py --config /etc/kuksa-dbc-feeder/config-sllin.ini
-Restart=on-failure
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb b/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb
deleted file mode 100644
index 75987905..00000000
--- a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "AGL demo configuration for HVAC service daemon"
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
-SECTION = "apps"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "file://agl-service-hvac-can.conf.demo \
- file://sllin.conf \
-"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-do_install () {
- # Install configuration file to use sllin0 instead of the default
- # can0 CAN device.
- install -D -m 644 ${WORKDIR}/agl-service-hvac-can.conf.demo ${D}${sysconfdir}/xdg/AGL/agl-service-hvac-can.conf
-
- # Install systemd override to add a dependency on kuksa-dbc-feeder-sllin.service,
- # which currently brings up sllin0. This will need to be reworked in the future
- # to be a bit more straightforward.
- install -d ${D}${systemd_system_unitdir}/agl-service-hvac.service.d
- install -m 0644 ${WORKDIR}/sllin.conf ${D}${systemd_system_unitdir}/agl-service-hvac.service.d/
-}
-
-FILES:${PN} += "${systemd_system_unitdir}"
-
-RDEPENDS:${PN} += "agl-service-hvac kuksa-dbc-feeder-sllin"
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/agl-service-hvac-can.conf.demo b/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/agl-service-hvac-can.conf.demo
deleted file mode 100644
index d2e0bb3d..00000000
--- a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/agl-service-hvac-can.conf.demo
+++ /dev/null
@@ -1,2 +0,0 @@
-[can]
-port = "sllin0"
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/sllin.conf b/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/sllin.conf
deleted file mode 100644
index f4df1855..00000000
--- a/recipes-demo/agl-service-hvac/agl-service-hvac-demo-conf/sllin.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-[Unit]
-Requires=kuksa-dbc-feeder-sllin.service
-After=kuksa-dbc-feeder-sllin.service
diff --git a/recipes-kernel/sllin/files/lin_config.conf b/recipes-kernel/sllin/files/lin_config.conf
deleted file mode 100644
index 9775b8b3..00000000
--- a/recipes-kernel/sllin/files/lin_config.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!--PCAN-LIN CT profile.-->
-<PCLIN_PROFILE Version="1">
- <LIN Group="2">
- <Scheduler_Entries Count="1">
- <!-- Poll steering wheel adapter at address 0x21 every 100 ms -->
- <Entry Time="100">33</Entry>
- </Scheduler_Entries>
- </LIN>
-</PCLIN_PROFILE>
diff --git a/recipes-kernel/sllin/files/sllin-demo.service b/recipes-kernel/sllin/files/sllin-demo.service
deleted file mode 100644
index e6af0be5..00000000
--- a/recipes-kernel/sllin/files/sllin-demo.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=LIN demo configuration
-ConditionPathExists=/dev/ttyUSB0
-
-[Service]
-Type=forking
-PIDFile=/run/lin_config/lin_config.pid
-ExecStart=/usr/bin/start_lin_demo.sh
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-kernel/sllin/files/start_lin_demo.sh b/recipes-kernel/sllin/files/start_lin_demo.sh
deleted file mode 100755
index c97f0a2c..00000000
--- a/recipes-kernel/sllin/files/start_lin_demo.sh
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-
-# Attach serial LIN->CAN bridge and set up LIN polling
-if [ -c /dev/ttyUSB0 ]; then
- sleep 1
- /usr/bin/lin_config -m -c /etc/lin_config.conf -a sllin:/dev/ttyUSB0
- mkdir -p /run/lin_config/
- pidof lin_config > /run/lin_config/lin_config.pid
- sleep 1
-else
- ip link add dev sllin0 type vcan
-fi
-ip link set sllin0 up
-
-# Initialize HVAC controller
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 02A#
-usleep 100000
-cansend sllin0 02B#
-usleep 100000
-cansend sllin0 032#F0F8FFFFFFFFFFFF
-usleep 100000
-cansend sllin0 032#F0F8FFFFFFFFFFFF
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 02D#
-usleep 100000
-cansend sllin0 02C#
-usleep 100000
-cansend sllin0 02D#
-usleep 100000
-cansend sllin0 02C#
-usleep 100000
-
diff --git a/recipes-kernel/sllin/sllin-demo.bb b/recipes-kernel/sllin/sllin-demo.bb
deleted file mode 100644
index bd764bea..00000000
--- a/recipes-kernel/sllin/sllin-demo.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "AGL IVI demo slLIN driver configuration"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://sllin-demo.service \
- file://start_lin_demo.sh \
- file://lin_config.conf \
-"
-
-SYSTEMD_SERVICE:${PN} = "sllin-demo.service"
-
-do_install:append () {
- install -d 644 ${D}/${bindir}
- install -m 0755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
-}
-
-FILES:${PN} += " \
- ${bindir}/start_lin_demo.sh \
- ${sysconfdir}/lin_config.conf \
-"
-
-RDEPENDS:${PN} += "lin-config"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
index 317b9005..2facd00f 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-preload.bb
@@ -12,17 +12,6 @@ PACKAGES = " \
# - demo-i2c-udev-conf:
# Adds udev configuration and scripts for supporting USB attached
# I2C devices for RTC and HVAC LED support.
-# - sllin-demo:
-# Adds systemd unit and scripting to drive configuring sllin
-# driver with lin-config utility, enabling HVAC fan control and
-# steering wheel controls in the demo.
-# - kuksa-dbc-feeder-sllin:
-# Adds configuration and systemd unit to run a second instance of
-# the DBC feeder against the sllin0 interface to connect the
-# steering wheel controls into VIS.
-# - agl-service-hvac-demo-conf:
-# Adds configuration to make agl-service-hvac use sllin0 for its
-# HVAC board control via CAN -> LIN.
# - simple-can-simulator:
# CAN message simulator for vehicle and engine speed message
# generation, with some support for the cruise control events from
@@ -31,8 +20,5 @@ PACKAGES = " \
RDEPENDS:${PN} = "\
packagegroup-agl-demo-platform \
demo-i2c-udev-conf \
- sllin-demo \
- kuksa-dbc-feeder-sllin \
- agl-service-hvac-demo-conf \
simple-can-simulator \
"