summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 12:47:48 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-01 08:58:18 +0000
commit758b0e80b1f137d2631b45e2533106bbc09f5810 (patch)
tree9ee8df117048436efae8fa5282989537dba7a891
parent63e0ea358f1902b1dd9968b21b5eea649d04329e (diff)
Remove lin bus componentsHEADmaster
We do no longer use lin bus components in the demo. Bug-AGL: SPEC-5189 Change-Id: Ie9b7a41f7f9b7e66b0adb26e3e26b1083a662b6a Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30043 Reviewed-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--recipes-core/distro-build-manifest/distro-build-manifest.bb164
-rw-r--r--recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch24
-rw-r--r--recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch108
-rw-r--r--recipes-kernel/sllin/sllin/0001-update-makefile.patch21
-rw-r--r--recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch25
-rw-r--r--recipes-kernel/sllin/sllin_git.bb22
-rw-r--r--recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch33
-rw-r--r--recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch20
-rw-r--r--recipes-support/lin-config/lin-config_git.bb25
9 files changed, 0 insertions, 442 deletions
diff --git a/recipes-core/distro-build-manifest/distro-build-manifest.bb b/recipes-core/distro-build-manifest/distro-build-manifest.bb
deleted file mode 100644
index 823cc28a..00000000
--- a/recipes-core/distro-build-manifest/distro-build-manifest.bb
+++ /dev/null
@@ -1,164 +0,0 @@
-SUMMARY = "Distribution build manifest"
-DESCRIPTION = "The folder /etc/platform-info contains build manifest (SPEC-720)."
-LICENSE = "MIT"
-
-# information distributed by the package is machine specific
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-# dependencies of ${DISTRO_MANIFEST_GENERATOR}
-DEPENDS = "coreutils-native bash-native git-native gawk-native sed-native jq-native"
-
-# force a rebuild everytime a build is started
-do_compile[nostamp] = "1"
-
-# borrowed to os-release.bb (output format is very close)
-python do_compilestep1 () {
- import shutil
- with open(d.expand('${B}/bbinfo-deploy'),'w') as f:
- allkeys=[]
- for field in d.getVar('BUILD_MANIFEST_FIELDS_DEPLOY').split():
- key='DIST_BB_{0}'.format(field)
- allkeys.append(key)
- value=d.getVar(field)
- if value:
- f.write('{0}="{1}"\n'.format(key,value))
- f.write('declare -A BITBAKE_VARS\nBITBAKE_VARS[deploy]="%s"' % ' '.join(allkeys))
-
- with open(d.expand('${B}/bbinfo-target'),'w') as f:
- allkeys=[]
- for field in d.getVar('BUILD_MANIFEST_FIELDS_TARGET').split():
- key='DIST_BB_{0}'.format(field)
- allkeys.append(key)
- value=d.getVar(field)
- if value:
- f.write('{0}="{1}"\n'.format(key,value))
- f.write('declare -A BITBAKE_VARS\nBITBAKE_VARS[target]="%s"' % ' '.join(allkeys))
-
- with open(d.expand('${B}/bbinfo-sdk'),'w') as f:
- allkeys=[]
- for field in d.getVar('BUILD_MANIFEST_FIELDS_SDK').split():
- key='DIST_BB_{0}'.format(field)
- allkeys.append(key)
- value=d.getVar(field)
- if value:
- f.write('{0}="{1}"\n'.format(key,value))
- f.write('declare -A BITBAKE_VARS\nBITBAKE_VARS[sdk]="%s"' % ' '.join(allkeys))
-}
-
-do_compilestep2 () {
- rc=99
- timestamp=${DATETIME}
- outfile=${B}/build-info
- if [ -x "${DISTRO_MANIFEST_GENERATOR}" -a -f "${DISTRO_SETUP_MANIFEST}" ]; then
- rc=0
- for format in bash json; do
- if [ "$format" = "json" ]; then
- ext=".json"
- else
- ext=""
- fi
- for mode in deploy target sdk; do
- ${DISTRO_MANIFEST_GENERATOR} -m $mode -f $format -t $timestamp -s ${B}/bbinfo-${mode} ${DISTRO_SETUP_MANIFEST} >${outfile}-${mode}${ext}
- rc=$?
- if [ $rc -ne 0 ]; then
- break
- fi
- done
- done
- else
- if [ -z "${DISTRO_MANIFEST_GENERATOR}" ]; then
- echo "The name of the generation script is not defined."
- elif [ ! -f "${DISTRO_MANIFEST_GENERATOR}" ]; then
- echo "Generation script ${DISTRO_MANIFEST_GENERATOR} is missing."
- elif [ ! -x "${DISTRO_MANIFEST_GENERATOR}" ]; then
- echo "Generation script ${DISTRO_MANIFEST_GENERATOR} isn't executable."
- fi
- if [ -z "${DISTRO_SETUP_MANIFEST}" ]; then
- echo "The name of the data file is not defined."
- elif [ ! -f "${DISTRO_SETUP_MANIFEST}" ]; then
- echo "Data file ${DISTRO_SETUP_MANIFEST} is missing."
- fi
- echo "You can try to rerun aglsetup.sh to solve that issue."
- echo "You can also try to source agl-init-build-env instead of oe-init-build-env."
- fi
-
- if [ "$rc" -ne 0 ]; then
- echo "distro-build-manifest generation failed."
- fi
- return $rc
-}
-
-do_compilestep1[vardeps] += " ${BUILD_MANIFEST_FIELDS_DEPLOY}"
-do_compilestep1[vardeps] += " ${BUILD_MANIFEST_FIELDS_TARGET}"
-do_compilestep1[vardeps] += " ${BUILD_MANIFEST_FIELDS_SDK}"
-
-# avoid errors "ERROR: When reparsing .../distro-build-manifest/distro-build-manifest.bb.do_compile, the basehash value changed from .... to .... . The metadata is not deterministic and this needs to be fixed."
-do_compilestep2[vardepsexclude] = "DATETIME"
-
-# combine the two steps
-python do_compile() {
- bb.build.exec_func("do_compilestep1",d)
- bb.build.exec_func("do_compilestep2",d)
-}
-
-do_install () {
- # install in target dir
- install -d ${D}${sysconfdir}/platform-info
- install -m 0644 build-info-target ${D}${sysconfdir}/platform-info/build
- install -m 0644 build-info-target.json ${D}${sysconfdir}/platform-info/build.json
-
- # also copy in deploy dir
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0644 build-info-deploy ${DEPLOY_DIR_IMAGE}/build-info
- install -m 0644 build-info-deploy.json ${DEPLOY_DIR_IMAGE}/build-info.json
-
- # copy into sdk deploy dir
- install -d ${DEPLOY_DIR}/sdk
- install -m 0644 build-info-sdk ${DEPLOY_DIR}/sdk/${SDK_NAME}.build-info
- install -m 0644 build-info-sdk.json ${DEPLOY_DIR}/sdk/${SDK_NAME}.build-info.json
-
- # and copy to nativesdk package
- # TODO
-}
-
-# list of variables to add to the various manifests
-# smalles one is 'target', then 'deploy' and finally 'sdk'
-BUILD_MANIFEST_FIELDS_TARGET = "\
- MACHINE_ARCH \
- MACHINEOVERRIDES \
- MACHINE_FEATURES \
- DISTRO_CODENAME \
- DISTRO_FEATURES \
- DISTRO_BRANCH_VERSION_TAG \
- AGLVERSION \
- AGL_BRANCH \
- AGLRELEASETYPE \
-"
-
-BUILD_MANIFEST_FIELDS_DEPLOY = "\
- ${BUILD_MANIFEST_FIELDS_TARGET} \
- DISTRO \
- DISTRO_VERSION \
- DISTROOVERRIDES \
- TUNE_FEATURES \
- TUNE_PKGARCH \
- ALL_MULTILIB_PACKAGE_ARCHS \
-"
-
-BUILD_MANIFEST_FIELDS_SDK = "\
- ${BUILD_MANIFEST_FIELDS_DEPLOY} \
- HOST_SYS \
- TARGET_SYS \
- TARGET_VENDOR \
- SDK_ARCH \
- SDK_VENDOR \
- SDK_VERSION \
- SDK_OS \
-"
-
-# dont exec useless tasks
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_patch[noexec] = "1"
-do_configure[noexec] = "1"
-
diff --git a/recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch b/recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch
deleted file mode 100644
index 51147081..00000000
--- a/recipes-kernel/sllin/files/0005-Fix-build-with-5.13-kernel.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Remove TTY_LDISC_MAGIC usage
-
-The 5.13 kernel removed the .magic field from tty_ldisc_ops and
-the associated TTY_LDISC_MAGIC #define, so remove their use when
-building for 5.13 or newer.
-
-Upstream-Status: Inappropriate [no upstream]
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
----
-diff --git a/sllin/sllin.c b/sllin/sllin.c
-index 92c52ad..904cff9 100644
---- a/sllin/sllin.c
-+++ b/sllin/sllin.c
-@@ -1619,7 +1619,9 @@ static int sllin_ioctl(struct tty_struct *tty, struct file *file,
-
- static struct tty_ldisc_ops sll_ldisc = {
- .owner = THIS_MODULE,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(5,13,0)
- .magic = TTY_LDISC_MAGIC,
-+#endif
- .name = "sllin",
- .open = sllin_open,
- .close = sllin_close,
diff --git a/recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch b/recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch
deleted file mode 100644
index bb0049f0..00000000
--- a/recipes-kernel/sllin/files/0006-Fix-build-with-5.14-kernel.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-Updates for 5.14
-
-The 5.14 kernel reworked the tty register and unregister call
-arguments, and made one of the arguments to the receive_buf
-callback const, add some kernel version conditionals to handle
-those.
-
-Upstream-Status: Inappropriate [no upstream]
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
----
- sllin/sllin.c | 29 ++++++++++++++++++++++++-----
- 1 file changed, 24 insertions(+), 5 deletions(-)
-
-diff --git a/sllin/sllin.c b/sllin/sllin.c
-index 904cff9..b89d06d 100644
---- a/sllin/sllin.c
-+++ b/sllin/sllin.c
-@@ -72,6 +72,12 @@
- #include <linux/version.h>
- #include "linux/lin_bus.h"
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+#define FP_CONST const
-+#else
-+#define FP_CONST
-+#endif
-+
- /* Should be in include/linux/tty.h */
- #define N_SLLIN 25
- /* -------------------------------- */
-@@ -185,9 +191,9 @@ struct sllin {
- static struct net_device **sllin_devs;
- static int sllin_configure_frame_cache(struct sllin *sl, struct can_frame *cf);
- static void sllin_slave_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count);
-+ const unsigned char *cp, FP_CONST char *fp, int count);
- static void sllin_master_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count);
-+ const unsigned char *cp, FP_CONST char *fp, int count);
-
-
- /* Values of two parity bits in LIN Protected
-@@ -492,7 +498,7 @@ static void sll_setup(struct net_device *dev)
- Routines looking at TTY side.
- ******************************************/
- static void sllin_master_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count)
-+ const unsigned char *cp, FP_CONST char *fp, int count)
- {
- struct sllin *sl = (struct sllin *) tty->disc_data;
-
-@@ -735,7 +741,7 @@ static void sllin_slave_finish_rx_msg(struct sllin *sl)
- }
-
- static void sllin_slave_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count)
-+ const unsigned char *cp, FP_CONST char *fp, int count)
- {
- struct sllin *sl = (struct sllin *) tty->disc_data;
- int lin_id;
-@@ -842,7 +848,7 @@ static void sllin_slave_receive_buf(struct tty_struct *tty,
- }
-
- static void sllin_receive_buf(struct tty_struct *tty,
-- const unsigned char *cp, char *fp, int count)
-+ const unsigned char *cp, FP_CONST char *fp, int count)
- {
- struct sllin *sl = (struct sllin *) tty->disc_data;
- netdev_dbg(sl->dev, "sllin_receive_buf invoked, count = %u\n", count);
-@@ -1619,6 +1625,9 @@ static int sllin_ioctl(struct tty_struct *tty, struct file *file,
-
- static struct tty_ldisc_ops sll_ldisc = {
- .owner = THIS_MODULE,
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+ .num = N_SLLIN,
-+#endif
- #if LINUX_VERSION_CODE < KERNEL_VERSION(5,13,0)
- .magic = TTY_LDISC_MAGIC,
- #endif
-@@ -1648,7 +1657,11 @@ static int __init sllin_init(void)
- }
-
- /* Fill in our line protocol discipline, and register it */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+ status = tty_register_ldisc(&sll_ldisc);
-+#else
- status = tty_register_ldisc(N_SLLIN, &sll_ldisc);
-+#endif
- if (status) {
- pr_err("sllin: can't register line discipline\n");
- kfree(sllin_devs);
-@@ -1719,9 +1732,15 @@ static void __exit sllin_exit(void)
- kfree(sllin_devs);
- sllin_devs = NULL;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5,14,0)
-+ tty_unregister_ldisc(&sll_ldisc);
-+
-+#else
- i = tty_unregister_ldisc(N_SLLIN);
-+
- if (i)
- pr_err("sllin: can't unregister ldisc (err %d)\n", i);
-+#endif
- }
-
- module_init(sllin_init);
diff --git a/recipes-kernel/sllin/sllin/0001-update-makefile.patch b/recipes-kernel/sllin/sllin/0001-update-makefile.patch
deleted file mode 100644
index 7db57802..00000000
--- a/recipes-kernel/sllin/sllin/0001-update-makefile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/sllin/Makefile b/sllin/Makefile
-index 8ae7510..037846f 100644
---- a/sllin/Makefile
-+++ b/sllin/Makefile
-@@ -1,10 +1,11 @@
- obj-m += sllin.o
--KPATH=/lib/modules/$(shell uname -r)/build
-+KPATH=$(KERNEL_SRC)
- #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/3.0.4
- #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/2.6.36
--
-+SRC := $(shell pwd)
- all:
-- make -C ${KPATH} M=$(PWD) modules
--
-+ make -C ${KPATH} M=$(SRC) modules
-+modules_install:
-+ make -C ${KPATH} M=$(SRC) modules_install
- clean:
-- make -C ${KPATH} M=$(PWD) clean
-+ make -C ${KPATH} M=$(SRC) clean
diff --git a/recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch b/recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch
deleted file mode 100644
index 8c13bfb5..00000000
--- a/recipes-kernel/sllin/sllin/0002-5.4-less-than-110-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Fix compilation against kernels < 5.4.110
-
-The fix to handle the backport of 4e096a18 to linux-5.4.y is a bit
-too broad, as it breaks building against kernels older than 5.4.110,
-add a version check to fix.
-
-Upstream-Status: pending
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/sllin/sllin.c b/sllin/sllin.c
-index b3f2636..a6fb120 100644
---- a/sllin/sllin.c
-+++ b/sllin/sllin.c
-@@ -1604,7 +1604,11 @@ static struct sllin *sll_alloc(dev_t line)
- sl = netdev_priv(dev);
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 4, 0)
- can_ml = (void *)sl + ALIGN(sizeof(*sl), NETDEV_ALIGN);
-+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 4, 110)
- can_set_ml_priv(dev, can_ml);
-+ #else
-+ dev->ml_priv = can_ml;
-+ #endif
- #endif
- /* Initialize channel control data */
- sl->magic = SLLIN_MAGIC;
diff --git a/recipes-kernel/sllin/sllin_git.bb b/recipes-kernel/sllin/sllin_git.bb
deleted file mode 100644
index f13bcd55..00000000
--- a/recipes-kernel/sllin/sllin_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "slLIN driver module"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://sllin.c;beginline=7;endline=37;md5=6408e14dba951f8cbe3c2a003a0d89d2"
-
-inherit module
-
-DEPENDS = "virtual/kernel"
-
-SRC_URI = "git://github.com/lin-bus/linux-lin.git;protocol=https;branch=master \
- file://0001-update-makefile.patch;pnum=2 \
- file://0002-5.4-less-than-110-fix.patch;pnum=2 \
-"
-SRCREV = "beb057d7505e0c4d7c61f3f4927b76916ec00e88"
-S = "${WORKDIR}/git/sllin"
-
-PV = "0.1+git${SRCPV}"
-
-KERNEL_MODULE_AUTOLOAD:append = " sllin"
-KERNEL_MODULE_PROBECONF:append = " sllin"
-
-SLLINBAUDRATE ??= "9600"
-module_conf_sllin = "options sllin baudrate=${SLLINBAUDRATE}"
diff --git a/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch b/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
deleted file mode 100644
index fe08b7d8..00000000
--- a/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 59acd73ba3bd6cc4151b890d135c6d690a83374d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
-Date: Tue, 1 Oct 2019 15:24:07 +0000
-Subject: [PATCH] Change Makefile to use pkg-config for libxml-2.0
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-instead of xml2-config.
-
-Upstream-Status: Pending
-
-Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
----
- lin_config/src/Makefile | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index cf5c515..3fc4df1 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,6 +1,5 @@
--CC=gcc
--CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `xml2-config --cflags` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
--LIBS=`xml2-config --libs` `pkg-config --libs libnl-route-3.0`
-+CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `pkg-config --cflags libxml-2.0` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
-+LIBS=`pkg-config --libs libxml-2.0` `pkg-config --libs libnl-route-3.0`
- INCLUDE=../../sllin
- DEBUG=-ggdb
-
---
-2.16.4
-
diff --git a/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch b/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
deleted file mode 100644
index 26364455..00000000
--- a/recipes-support/lin-config/files/0002-Change-Makefile-to-use-LDFLAGS.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Use LDFLAGS when linking
-
-Use LDFLAGS when linking the output binary to quiet QA warnings due to
-missing link flags.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
---- a/Makefile 2019-11-05 11:08:11.060565285 +0000
-+++ b/Makefile 2019-11-05 11:09:38.663570084 +0000
-@@ -6,7 +6,7 @@
- objects = linc_parse_xml.o pcl_config.o sllin_config.o lin_config.o
-
- lin_config: $(objects)
-- $(CC) $(objects) $(LIBS) -o lin_config
-+ $(CC) $(LDFLAGS) $(objects) $(LIBS) -o lin_config
-
- %.o : %.c %.h
- $(CC) $(CFLAGS) $(LIBS) -c $< -o $@
diff --git a/recipes-support/lin-config/lin-config_git.bb b/recipes-support/lin-config/lin-config_git.bb
deleted file mode 100644
index a8c8f4fc..00000000
--- a/recipes-support/lin-config/lin-config_git.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "lin-config tool for the sllin driver module"
-LICENSE = "GPL-2.0-only"
-LIC_FILES_CHKSUM = "file://lin_config.c;beginline=4;endline=9;md5=196a29df19a30dbc752937bdfc819d7a"
-
-DEPENDS += "libnl libxml2"
-
-SRC_URI = "git://github.com/lin-bus/linux-lin.git;protocol=https;branch=master"
-SRCREV = "beb057d7505e0c4d7c61f3f4927b76916ec00e88"
-S = "${WORKDIR}/git/lin_config/src"
-
-SRC_URI:append = " \
- file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
- file://0002-Change-Makefile-to-use-LDFLAGS.patch \
- "
-
-inherit pkgconfig
-
-PV = "0.1+git${SRCPV}"
-
-do_configure[noexec] = "1"
-
-do_install:append() {
- install -d ${D}/${bindir}
- install -m 755 ${S}/lin_config ${D}/${bindir}
-}