summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:47:27 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 15:49:13 +0000
commit9eda76e3a9c869030ff4bcf66704207753666a6c (patch)
tree8a77cbed19e883f177f14844c539351b15134b5b
parent7a356a7e84f6fc7b67a725cfb27d432b782ab43e (diff)
agl-dbc: Add recipe
Add recipe to install the agl-vcar.dbc CAN database file from the newly created agl-dbc repository, remove the copy installed by the kuksa-can-provider-conf-agl recipe, and update various references to it for the new on target path under /usr/share/dbc. Bug-AGL: SPEC-5119 Change-Id: I9a21128c6daa13761e575bad4363be09a3efe808 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30039 ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account
-rw-r--r--recipes-connectivity/kuksa-val/agl-dbc_git.bb21
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb4
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/agl-vcar.dbc69
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/config.ini2
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-can-provider-conf-gw-hardware/config.ini.gw-hardware2
5 files changed, 24 insertions, 74 deletions
diff --git a/recipes-connectivity/kuksa-val/agl-dbc_git.bb b/recipes-connectivity/kuksa-val/agl-dbc_git.bb
new file mode 100644
index 00000000..ee36f9b6
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/agl-dbc_git.bb
@@ -0,0 +1,21 @@
+SUMMARY = "CAN database (DBC) files for AGL demos"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f814e94ea4f54c1cdeb3fa60579ca000"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-dbc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "e215d8663370fcdb477d1bc20b434b7e4295fab7"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d ${D}${datadir}/dbc
+ install -m 0644 ${S}/agl-vcar.dbc ${D}${datadir}/dbc/
+}
+
+FILES:${PN} += "${datadir}/dbc"
diff --git a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
index 64f194d7..aadbb2dd 100644
--- a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
+++ b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl.bb
@@ -7,7 +7,6 @@ SRC_URI = "file://config.ini \
file://can-provider.token \
file://dbc_default_values.json \
file://can-dev-helper.conf \
- file://agl-vcar.dbc \
"
S = "${WORKDIR}"
@@ -21,12 +20,11 @@ do_install() {
install -m 0644 ${WORKDIR}/config.ini ${D}${sysconfdir}/kuksa-can-provider/
install -m 0644 ${WORKDIR}/can-provider.token ${D}${sysconfdir}/kuksa-can-provider/
install -m 0644 ${WORKDIR}/dbc_default_values.json ${D}${sysconfdir}/kuksa-can-provider/
- install -m 0644 ${WORKDIR}/agl-vcar.dbc ${D}${sysconfdir}/kuksa-can-provider/
install -d ${D}${systemd_system_unitdir}/kuksa-can-provider.service.d
install -m 0644 ${WORKDIR}/can-dev-helper.conf ${D}${systemd_system_unitdir}/kuksa-can-provider.service.d/
}
FILES:${PN} += "${systemd_system_unitdir}"
-RDEPENDS:${PN} += "kuksa-can-provider can-dev-helper"
+RDEPENDS:${PN} += "kuksa-can-provider agl-dbc can-dev-helper"
RPROVIDES:${PN} += "kuksa-can-provider-conf"
diff --git a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/agl-vcar.dbc b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/agl-vcar.dbc
deleted file mode 100644
index e638d128..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/agl-vcar.dbc
+++ /dev/null
@@ -1,69 +0,0 @@
-VERSION "AGL Virtual Car 1.0"
-
-BS_:
-
-BO_ 1001 Vehicle_Status_1: 8 Vector_XXX
- SG_ PT_VehicleAvgSpeed : 7|15@0+ (0.015625,0) [0|0] "" Vector_XXX
-
-BO_ 985 Vehicle_Status_2: 8 Vector_XXX
- SG_ PT_FuelLevelPct : 8|8@1+ (0.392157,0) [0|0] "" Vector_XXX
- SG_ PT_EngineSpeed : 23|16@0+ (0.25,0) [0|0] "" Vector_XXX
- SG_ PT_FuelLevelLow : 55|1@1+ (1,0) [0|1] "" Vector_XXX
-
-BO_ 986 Vehicle_Status_3: 8 Vector_XXX
- SG_ PT_HazardOn : 0|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ PT_LeftTurnOn : 1|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ PT_RightTurnOn : 2|1@1+ (1,0) [0|1] "" Vector_XXX
-
-BO_ 48 HVAC_Control_1: 8 Vector_XXX
- SG_ PT_TempLeft : 7|8@0+ (0.4166666667,0) [0|100] "C" Vector_XXX
- SG_ PT_TempRight : 15|8@0+ (0.4166666667,0) [0|100] "C" Vector_XXX
- SG_ PT_FanSpeed : 39|8@0+ (0.392157,0) [0|100] "%" Vector_XXX
-
-BO_ 401 Engine: 8 Vector__XXX
- SG_ ThrottlePosition : 63|8@0+ (0.392157,0) [0|100.000035] "%" Vector__XXX
-
-BO_ 381 ABS: 8 Vector__XXX
- SG_ VehicleSpeed : 7|12@0+ (0.0625,0) [0|255.9375] "km / h" ECM_HS,BCM_HS
- SG_ SteeringPosition : 23|12@0+ (0.0439453125,-90) [-90|89.9560546875] "deg" ECM_HS,BCM_HS
- SG_ BrakePressure : 39|8@0+ (75,0) [0|19125] "kPa" ECM_HS,BCM_HS
-
-BO_ 532 Transmission: 8 Vector__XXX
- SG_ Gear : 7|8@0+ (1,-1) [-1|127] "" ECM_HS,BCM_HS
-
-BO_ 533 Airbag: 8 Vector__XXX
- SG_ CollisionIntensity : 7|12@0+ (24.4140625,0) [0|100000] "N" ECM_HS,BCM_HS
-
-BO_ 534 IMU1: 8 Vector__XXX
- SG_ AccelerationX : 7|12@0+ (0.48828125,-1000) [-1000|1000] "m/s^2" ECM_HS,BCM_HS
- SG_ AccelerationY : 23|12@0+ (0.48828125,-1000) [-1000|1000] "m/s^2" ECM_HS,BCM_HS
- SG_ AccelerationZ : 39|12@0+ (0.48828125,-1000) [-1000|1000] "m/s^2" ECM_HS,BCM_HS
-
-BO_ 535 IMU2: 8 Vector__XXX
- SG_ GyroscopeX : 7|12@0+ (0.48828125,-1000) [-1000|1000] "rad/s" ECM_HS,BCM_HS
- SG_ GyroscopeY : 23|12@0+ (0.48828125,-1000) [-1000|1000] "rad/s" ECM_HS,BCM_HS
- SG_ GyroscopeZ : 39|12@0+ (0.48828125,-1000) [-1000|1000] "rad/s" ECM_HS,BCM_HS
-
-BO_ 536 GNSS: 8 Vector__XXX
- SG_ Latitude : 7|32@0+ (0.0000000419095158577,-90) [-90|90] "deg" ECM_HS,BCM_HS
- SG_ Longitude : 39|32@0+ (0.00000008381903171539,-180) [-180|180] "deg" ECM_HS,BCM_HS
-
-BO_ 33 Steering_Wheel: 8 Vector_XXX
- SG_ SW_Previous : 39|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_VolumeUp : 38|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_Mode : 37|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_VolumeDown : 36|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_Next : 35|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_Info : 33|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_VolumeMute : 32|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_Voice : 42|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_PhoneHangup : 41|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_PhoneCall : 40|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_CruiseEnable : 55|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_CruiseResume : 54|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_CruiseSet : 52|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_CruiseCancel : 51|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_CruiseLimit : 49|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_CruiseDistance : 48|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_Horn : 63|1@1+ (1,0) [0|1] "" Vector_XXX
- SG_ SW_LaneDepartureWarning : 56|1@1+ (1,0) [0|1] "" Vector_XXX
diff --git a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/config.ini b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/config.ini
index f41fb87a..b4f47a37 100644
--- a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/config.ini
+++ b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-agl/config.ini
@@ -27,4 +27,4 @@ port = can0
# Enable SAE-J1939 Mode. False: ignore
j1939 = False
# DBC file used to parse CAN messages
-dbcfile = /etc/kuksa-can-provider/agl-vcar.dbc
+dbcfile = /usr/share/dbc/agl-vcar.dbc
diff --git a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-gw-hardware/config.ini.gw-hardware b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-gw-hardware/config.ini.gw-hardware
index 6f29d121..6d7b2920 100644
--- a/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-gw-hardware/config.ini.gw-hardware
+++ b/recipes-connectivity/kuksa-val/kuksa-can-provider-conf-gw-hardware/config.ini.gw-hardware
@@ -27,4 +27,4 @@ port = can1
# Enable SAE-J1939 Mode. False: ignore
j1939 = False
# DBC file used to parse CAN messages
-dbcfile = /etc/kuksa-can-provider/agl-vcar.dbc
+dbcfile = /usr/share/dbc/agl-vcar.dbc