summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-10 15:19:59 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-11 12:25:36 +0000
commitaae4e6dbcf7836f49eef755164c3ee1fd0142883 (patch)
tree70f186b02b329a576ed1884ac4b061579a88bb58
parent61bdecebdc9990ad7e3f02697cbeeedfcde28461 (diff)
python3-grpcio: remove bbappend
Testing has shown that the libatomic linking fix for RISC-V (see SPEC-5011) is not needed after the upgrade to scarthgap, so remove our bbappend. Bug-AGL: SPEC-5171 Change-Id: I0d6c29cd0c150f63f267ebae69749be3fc4ed40c Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29984 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--recipes-devtools/python/python3-grpcio_1.62.%.bbappend1
-rw-r--r--recipes-devtools/python/python3-grpcio_agldemo.inc17
2 files changed, 0 insertions, 18 deletions
diff --git a/recipes-devtools/python/python3-grpcio_1.62.%.bbappend b/recipes-devtools/python/python3-grpcio_1.62.%.bbappend
deleted file mode 100644
index 26036fc8..00000000
--- a/recipes-devtools/python/python3-grpcio_1.62.%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'python3-grpcio_agldemo.inc', '', d)}
diff --git a/recipes-devtools/python/python3-grpcio_agldemo.inc b/recipes-devtools/python/python3-grpcio_agldemo.inc
deleted file mode 100644
index 8236a341..00000000
--- a/recipes-devtools/python/python3-grpcio_agldemo.inc
+++ /dev/null
@@ -1,17 +0,0 @@
-# For some reason the atomics presence test in the grpc build
-# passes on RISC-V even though linking with libatomic is actually
-# needed. There are some mentions on the web of some atomics
-# support incorrectly being in the libc stub on RISC-V, so a
-# fix could be tracking down if that is the case and if it has
-# been fixed in newer libc. Otherwise, the compile test in grpc
-# will need to be changed to some other function that is known to
-# only be in libatomic on RISC-V.
-#
-# The next problem is that setting GRPC_PYTHON_LDFLAGS to any value
-# ends up not adding linking with pthread due to the way the logic
-# is set up, so we need to actually add it explicitly. The upstream
-# recipe seems slightly broken in this respect.
-
-GRPC_LDFLAGS ?= " -lpthread"
-GRPC_LDFLAGS:append:riscv64 = " -latomic"
-export GRPC_PYTHON_LDFLAGS = "${GRPC_LDFLAGS}"