summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-18 16:13:35 -0400
committerScott Murray <scott.murray@konsulko.com>2024-06-20 02:04:33 +0000
commitd9f9ddd177a57110d9c67ea438436c3160f8e429 (patch)
tree057eb6ee90e025743c374d428138b57358f7d554
parentd0078bc67f253d971e94f13426ecf8bb10079784 (diff)
kuksa-client: Upgrade to 0.4.3
Upgrade kuksa-client to 0.4.3 release. One of our local patches has been dropped as it is no longer applicable, and a new one has been added to allow building with the version of python3-grpcio-tools available in YP scarthgap. Bug-AGL: SPEC-5179 Change-Id: I6fb3ff8cd63cec924dc4180ac4f44d3ac0c1996f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30001 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-client/0001-kuksa-client-Update-cmd2-completer-usage.patch30
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-client/0002-Tweak-grpcio-tools-requirement.patch30
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-client/0002-kuksa-client-Add-external-certificates-support.patch51
-rw-r--r--recipes-connectivity/kuksa-val/kuksa-client_git.bb6
4 files changed, 48 insertions, 69 deletions
diff --git a/recipes-connectivity/kuksa-val/kuksa-client/0001-kuksa-client-Update-cmd2-completer-usage.patch b/recipes-connectivity/kuksa-val/kuksa-client/0001-kuksa-client-Update-cmd2-completer-usage.patch
index e32e5c46..3f552738 100644
--- a/recipes-connectivity/kuksa-val/kuksa-client/0001-kuksa-client-Update-cmd2-completer-usage.patch
+++ b/recipes-connectivity/kuksa-val/kuksa-client/0001-kuksa-client-Update-cmd2-completer-usage.patch
@@ -1,4 +1,4 @@
-From 89aa41f52d5946796ad8dea587cd848aef71c8c0 Mon Sep 17 00:00:00 2001
+From acb2bbff3de6e9f0bafb8b96a339820a9ddfadca Mon Sep 17 00:00:00 2001
From: Scott Murray <scott.murray@konsulko.com>
Date: Mon, 27 Nov 2023 15:31:02 -0500
Subject: [PATCH 1/2] kuksa-client: Update cmd2 completer usage
@@ -14,7 +14,7 @@ Signed-off-by: Scott Murray <scott.murray@konsulko.com>
1 file changed, 16 insertions(+), 17 deletions(-)
diff --git a/kuksa-client/kuksa_client/__main__.py b/kuksa-client/kuksa_client/__main__.py
-index 032410b..1d2d1fc 100755
+index 2b29623..7061ec1 100755
--- a/kuksa-client/kuksa_client/__main__.py
+++ b/kuksa-client/kuksa_client/__main__.py
@@ -36,7 +36,6 @@ from cmd2 import CompletionItem
@@ -24,8 +24,8 @@ index 032410b..1d2d1fc 100755
-from cmd2.utils import basic_complete
from urllib.parse import urlparse
- from kuksa_client import kuksa_server_certificates
-@@ -156,7 +155,7 @@ class TestClient(Cmd):
+ from kuksa_client import KuksaClientThread
+@@ -151,7 +150,7 @@ class TestClient(Cmd):
self.pathCompletionItems = []
for sub_id in self.subscribeIds:
self.pathCompletionItems.append(CompletionItem(sub_id))
@@ -33,8 +33,8 @@ index 032410b..1d2d1fc 100755
+ return Cmd.basic_complete(self, text, line, begidx, endidx, self.pathCompletionItems)
COMM_SETUP_COMMANDS = "Communication Set-up Commands"
- VSS_COMMANDS = "Kuksa Interaction Commands"
-@@ -171,19 +170,19 @@ class TestClient(Cmd):
+ VSS_COMMANDS = "Kuksa Interaction Commands (Supported by both KUKSA Databroker and KUKSA Server)"
+@@ -167,19 +166,19 @@ class TestClient(Cmd):
ap_disconnect = argparse.ArgumentParser()
ap_authorize = argparse.ArgumentParser()
@@ -57,7 +57,7 @@ index 032410b..1d2d1fc 100755
)
ap_setValue.add_argument("Value", nargs="+", help="Value to be set")
ap_setValue.add_argument(
-@@ -203,7 +202,7 @@ class TestClient(Cmd):
+@@ -199,7 +198,7 @@ class TestClient(Cmd):
ap_getValue = argparse.ArgumentParser()
ap_getValue.add_argument(
@@ -66,7 +66,7 @@ index 032410b..1d2d1fc 100755
)
ap_getValue.add_argument(
"-a", "--attribute", help="Attribute to be get", default="value"
-@@ -214,7 +213,7 @@ class TestClient(Cmd):
+@@ -210,7 +209,7 @@ class TestClient(Cmd):
"Path",
help="Path whose value is to be read",
nargs="+",
@@ -75,7 +75,7 @@ index 032410b..1d2d1fc 100755
)
ap_getValues.add_argument(
"-a", "--attribute", help="Attribute to be get", default="value"
-@@ -224,7 +223,7 @@ class TestClient(Cmd):
+@@ -220,7 +219,7 @@ class TestClient(Cmd):
ap_setTargetValue.add_argument(
"Path",
help="Path whose target value to be set",
@@ -84,7 +84,7 @@ index 032410b..1d2d1fc 100755
)
ap_setTargetValue.add_argument("Value", help="Value to be set")
-@@ -240,7 +239,7 @@ class TestClient(Cmd):
+@@ -236,7 +235,7 @@ class TestClient(Cmd):
ap_getTargetValue.add_argument(
"Path",
help="Path whose target value is to be read",
@@ -93,7 +93,7 @@ index 032410b..1d2d1fc 100755
)
ap_getTargetValues = argparse.ArgumentParser()
-@@ -248,12 +247,12 @@ class TestClient(Cmd):
+@@ -244,12 +243,12 @@ class TestClient(Cmd):
"Path",
help="Path whose target value is to be read",
nargs="+",
@@ -108,7 +108,7 @@ index 032410b..1d2d1fc 100755
)
ap_subscribe.add_argument(
"-a", "--attribute", help="Attribute to subscribe to", default="value"
-@@ -268,7 +267,7 @@ class TestClient(Cmd):
+@@ -264,7 +263,7 @@ class TestClient(Cmd):
ap_subscribeMultiple = argparse.ArgumentParser()
ap_subscribeMultiple.add_argument(
@@ -117,7 +117,7 @@ index 032410b..1d2d1fc 100755
)
ap_subscribeMultiple.add_argument(
"-a", "--attribute", help="Attribute to subscribe to", default="value"
-@@ -284,18 +283,18 @@ class TestClient(Cmd):
+@@ -280,18 +279,18 @@ class TestClient(Cmd):
ap_unsubscribe.add_argument(
"SubscribeId",
help="Corresponding subscription Id",
@@ -139,7 +139,7 @@ index 032410b..1d2d1fc 100755
)
ap_updateMetaData.add_argument(
"Json",
-@@ -304,14 +303,14 @@ class TestClient(Cmd):
+@@ -300,14 +299,14 @@ class TestClient(Cmd):
)
ap_updateVSSTree = argparse.ArgumentParser()
@@ -157,5 +157,5 @@ index 032410b..1d2d1fc 100755
# Constructor, request names after protocol to avoid errors
--
-2.42.0
+2.44.0
diff --git a/recipes-connectivity/kuksa-val/kuksa-client/0002-Tweak-grpcio-tools-requirement.patch b/recipes-connectivity/kuksa-val/kuksa-client/0002-Tweak-grpcio-tools-requirement.patch
new file mode 100644
index 00000000..fef2265b
--- /dev/null
+++ b/recipes-connectivity/kuksa-val/kuksa-client/0002-Tweak-grpcio-tools-requirement.patch
@@ -0,0 +1,30 @@
+From 43823a52a9cb25d906542d15dc207f6516579aa3 Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Tue, 18 Jun 2024 16:08:13 -0400
+Subject: [PATCH 2/2] Tweak grpcio-tools requirement
+
+Lower grpcio-tools requirement to 1.62.0 so building on YP scarthgap
+is possible.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ kuksa-client/pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/kuksa-client/pyproject.toml b/kuksa-client/pyproject.toml
+index a7afaca..a8d70ff 100644
+--- a/kuksa-client/pyproject.toml
++++ b/kuksa-client/pyproject.toml
+@@ -1,6 +1,6 @@
+ [build-system]
+ requires = [
+- "grpcio-tools>=1.63.0",
++ "grpcio-tools>=1.62.0",
+ "setuptools>=42",
+ "setuptools-git-versioning",
+ "wheel",
+--
+2.44.0
+
diff --git a/recipes-connectivity/kuksa-val/kuksa-client/0002-kuksa-client-Add-external-certificates-support.patch b/recipes-connectivity/kuksa-val/kuksa-client/0002-kuksa-client-Add-external-certificates-support.patch
deleted file mode 100644
index adc19e6f..00000000
--- a/recipes-connectivity/kuksa-val/kuksa-client/0002-kuksa-client-Add-external-certificates-support.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 3f3dbe36b4adcdd7c3cef41980058331e79ce620 Mon Sep 17 00:00:00 2001
-From: Scott Murray <scott.murray@konsulko.com>
-Date: Sat, 5 Aug 2023 13:27:44 -0400
-Subject: [PATCH 2/2] kuksa_viss_client: Add external certificates support
-
-Tweak the definition of __certificate_dir__ in the kuksa_certificates
-package, and certificate location logic in the client library to allow
-picking up alternative certificates from /etc/kuksa-certificates or
-/etc/kuksa-val before falling back to the shipped defaults. The
-intent is to allow packagers to more straighhtforwardly use their own
-certificates with both the server and clients.
-
-Upstream-Status: pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
- kuksa-client/kuksa_client/cli_backend/__init__.py | 2 +-
- kuksa-client/kuksa_client/kuksa_server_certificates/__init__.py | 7 ++++++-
- 2 files changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/kuksa-client/kuksa_client/cli_backend/__init__.py b/kuksa-client/kuksa_client/cli_backend/__init__.py
-index 2cfe51e..96d94f2 100644
---- a/kuksa-client/kuksa_client/cli_backend/__init__.py
-+++ b/kuksa-client/kuksa_client/cli_backend/__init__.py
-@@ -28,7 +28,7 @@ class Backend:
- self.insecure = config.getboolean('insecure', False)
- except AttributeError:
- self.insecure = config.get('insecure', False)
-- self.default_cert_path = pathlib.Path(kuksa_server_certificates.__path__[0])
-+ self.default_cert_path = pathlib.Path(kuksa_server_certificates.__certificate_dir__)
- self.cacertificate = config.get(
- 'cacertificate', str(self.default_cert_path / 'CA.pem'))
- self.certificate = config.get('certificate', str(
-diff --git a/kuksa-client/kuksa_client/kuksa_server_certificates/__init__.py b/kuksa-client/kuksa_client/kuksa_server_certificates/__init__.py
-index 22ccd3f..8323868 100644
---- a/kuksa-client/kuksa_client/kuksa_server_certificates/__init__.py
-+++ b/kuksa-client/kuksa_client/kuksa_server_certificates/__init__.py
-@@ -2,4 +2,9 @@ import os
-
- from kuksa_client._metadata import *
-
--__certificate_dir__= os.path.dirname(os.path.realpath(__file__))
-+if os.path.isdir("/etc/kuksa-certificates"):
-+ __certificate_dir__= "/etc/kuksa-certificates"
-+elif os.path.isdir("/etc/kuksa-val"):
-+ __certificate_dir__= "/etc/kuksa-val"
-+else:
-+ __certificate_dir__= os.path.dirname(os.path.realpath(__file__))
---
-2.41.0
-
diff --git a/recipes-connectivity/kuksa-val/kuksa-client_git.bb b/recipes-connectivity/kuksa-val/kuksa-client_git.bb
index 944a2014..e12816ad 100644
--- a/recipes-connectivity/kuksa-val/kuksa-client_git.bb
+++ b/recipes-connectivity/kuksa-val/kuksa-client_git.bb
@@ -11,13 +11,13 @@ DEPENDS = " \
python3-grpcio \
"
-PV = "0.4.2"
+PV = "0.4.3"
SRC_URI = "gitsm://github.com/eclipse-kuksa/kuksa-python-sdk.git;protocol=https;branch=main \
file://0001-kuksa-client-Update-cmd2-completer-usage.patch;patchdir=.. \
- file://0002-kuksa-client-Add-external-certificates-support.patch;patchdir=.. \
+ file://0002-Tweak-grpcio-tools-requirement.patch;patchdir=.. \
"
-SRCREV = "4ac107a638c8dbf5cde1743a3df2e28589990332"
+SRCREV = "d72777a6aec6bd9f9a2bdf5ae5d01a9bc2de423a"
S = "${WORKDIR}/git/kuksa-client"